USN-6577-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6577-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6577-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6577-1
Related
Published
2024-01-10T22:36:53.759766Z
Modified
2024-01-10T22:36:53.759766Z
Summary
linux-aws vulnerabilities
Details

Jana Hofmann, Emanuele Vannacci, Cedric Fournet, Boris Kopf, and Oleksii Oleksenko discovered that some AMD processors could leak stale data from division operations in certain situations. A local attacker could possibly use this to expose sensitive information. (CVE-2023-20588)

It was discovered that a race condition existed in the Linux kernel when performing operations with kernel objects, leading to an out-of-bounds write. A local attacker could use this to cause a denial of service (system crash) or execute arbitrary code. (CVE-2023-45863)

References

Affected packages

Ubuntu:Pro:16.04:LTS / linux-aws

Package

Name
linux-aws

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.4.0-1164.179

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "linux-aws-tools-4.4.0-1164": "4.4.0-1164.179",
            "linux-modules-extra-4.4.0-1164-aws": "4.4.0-1164.179",
            "linux-aws-cloud-tools-4.4.0-1164": "4.4.0-1164.179",
            "linux-tools-4.4.0-1164-aws": "4.4.0-1164.179",
            "linux-headers-aws": "4.4.0.1164.168",
            "linux-buildinfo-4.4.0-1164-aws": "4.4.0-1164.179",
            "linux-modules-4.4.0-1164-aws": "4.4.0-1164.179",
            "linux-aws": "4.4.0.1164.168",
            "linux-image-aws": "4.4.0.1164.168",
            "linux-modules-extra-aws": "4.4.0.1164.168",
            "linux-aws-headers-4.4.0-1164": "4.4.0-1164.179",
            "linux-image-4.4.0-1164-aws": "4.4.0-1164.179",
            "linux-cloud-tools-4.4.0-1164-aws": "4.4.0-1164.179",
            "linux-headers-4.4.0-1164-aws": "4.4.0-1164.179",
            "linux-tools-aws": "4.4.0.1164.168"
        }
    ]
}