USN-6596-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6596-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6596-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6596-1
Related
Published
2024-01-24T11:12:41.066702Z
Modified
2024-01-24T11:12:41.066702Z
Summary
libapache-session-ldap-perl vulnerability
Details

It was discovered that Apache::Session::LDAP incorrectly handled invalid X.509 certificates. If a user or an automated system were tricked into opening a specially crafted invalid X.509 certificate, a remote attacker could possibly use this issue to perform spoofing and obtain sensitive information.

References

Affected packages

Ubuntu:Pro:18.04:LTS / libapache-session-ldap-perl

Package

Name
libapache-session-ldap-perl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.4-1ubuntu0.18.04.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libapache-session-ldap-perl": "0.4-1ubuntu0.18.04.1~esm1"
        }
    ]
}

Ubuntu:20.04:LTS / libapache-session-ldap-perl

Package

Name
libapache-session-ldap-perl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.4-1+deb10u1build0.20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libapache-session-ldap-perl": "0.4-1+deb10u1build0.20.04.1"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / libapache-session-ldap-perl

Package

Name
libapache-session-ldap-perl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.4-1ubuntu0.16.04.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libapache-session-ldap-perl": "0.4-1ubuntu0.16.04.1~esm1"
        }
    ]
}