USN-6597-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6597-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6597-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6597-1
Related
Published
2024-01-25T12:38:55.381253Z
Modified
2024-01-25T12:38:55.381253Z
Summary
puma vulnerability
Details

It was discovered that Puma incorrectly handled parsing chunked transfer encoding bodies. A remote attacker could possibly use this issue to cause Puma to consume resources, leading to a denial of service.

References

Affected packages

Ubuntu:23.10 / puma

Package

Name
puma

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.6.5-4ubuntu2.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "puma": "5.6.5-4ubuntu2.1"
        }
    ]
}