USN-6643-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6643-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6643-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6643-1
Related
Published
2024-02-19T17:14:36.858938Z
Modified
2024-02-19T17:14:36.858938Z
Summary
node-ip vulnerability
Details

Emre Durmaz discovered that NPM IP package incorrectly distinguished between private and public IP addresses. A remote attacker could possibly use this issue to perform Server-Side Request Forgery (SSRF) attacks.

References

Affected packages

Ubuntu:Pro:18.04:LTS / node-ip

Package

Name
node-ip

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.1.5-1ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "node-ip": "1.1.5-1ubuntu0.1~esm1"
        }
    ]
}

Ubuntu:Pro:20.04:LTS / node-ip

Package

Name
node-ip

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.1.5-5ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "node-ip": "1.1.5-5ubuntu0.1~esm1"
        }
    ]
}

Ubuntu:Pro:22.04:LTS / node-ip

Package

Name
node-ip

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.1.5+~1.1.0-1ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "node-ip": "1.1.5+~1.1.0-1ubuntu0.1~esm1"
        }
    ]
}

Ubuntu:23.10 / node-ip

Package

Name
node-ip

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.0.0+~1.1.0-1ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "node-ip": "2.0.0+~1.1.0-1ubuntu0.1"
        }
    ]
}