USN-6651-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6651-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6651-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6651-1
Related
Published
2024-02-23T19:36:52.989491Z
Modified
2024-02-23T19:36:52.989491Z
Summary
linux, linux-aws, linux-gcp, linux-hwe-6.5, linux-laptop, linux-oracle, linux-raspi, linux-starfive vulnerabilities
Details

It was discovered that a race condition existed in the ATM (Asynchronous Transfer Mode) subsystem of the Linux kernel, leading to a use-after-free vulnerability. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2023-51780)

It was discovered that a race condition existed in the AppleTalk networking subsystem of the Linux kernel, leading to a use-after-free vulnerability. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2023-51781)

Zhenghan Wang discovered that the generic ID allocator implementation in the Linux kernel did not properly check for null bitmap when releasing IDs. A local attacker could use this to cause a denial of service (system crash). (CVE-2023-6915)

Robert Morris discovered that the CIFS network file system implementation in the Linux kernel did not properly validate certain server commands fields, leading to an out-of-bounds read vulnerability. An attacker could use this to cause a denial of service (system crash) or possibly expose sensitive information. (CVE-2024-0565)

Jann Horn discovered that the io_uring subsystem in the Linux kernel did not properly handle the release of certain buffer rings. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2024-0582)

Jann Horn discovered that the TLS subsystem in the Linux kernel did not properly handle spliced messages, leading to an out-of-bounds write vulnerability. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2024-0646)

References

Affected packages

Ubuntu:22.04:LTS / linux-hwe-6.5

Package

Name
linux-hwe-6.5

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
6.5.0-21.21~22.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-tools-generic-64k-hwe-22.04": "6.5.0.21.21~22.04.11",
            "linux-headers-generic-hwe-22.04-edge": "6.5.0.21.21~22.04.11",
            "linux-headers-virtual-hwe-22.04-edge": "6.5.0.21.21~22.04.11",
            "linux-hwe-6.5-tools-host": "6.5.0-21.21~22.04.1",
            "linux-image-uc-6.5.0-21-generic-64k": "6.5.0-21.21~22.04.1",
            "linux-headers-6.5.0-21-generic": "6.5.0-21.21~22.04.1",
            "linux-modules-ivsc-6.5.0-21-generic": "6.5.0-21.21~22.04.1",
            "linux-tools-generic-hwe-22.04-edge": "6.5.0.21.21~22.04.11",
            "linux-generic-64k-hwe-22.04-edge": "6.5.0.21.21~22.04.11",
            "linux-hwe-6.5-tools-6.5.0-21": "6.5.0-21.21~22.04.1",
            "linux-image-generic-hwe-22.04-edge": "6.5.0.21.21~22.04.11",
            "linux-headers-virtual-hwe-22.04": "6.5.0.21.21~22.04.11",
            "linux-image-uc-generic-hwe-22.04-edge": "6.5.0.21.21~22.04.11",
            "linux-hwe-6.5-headers-6.5.0-21": "6.5.0-21.21~22.04.1",
            "linux-modules-iwlwifi-generic-hwe-22.04": "6.5.0.21.21~22.04.11",
            "linux-image-virtual-hwe-22.04": "6.5.0.21.21~22.04.11",
            "linux-tools-generic-64k-hwe-22.04-edge": "6.5.0.21.21~22.04.11",
            "linux-modules-extra-6.5.0-21-generic": "6.5.0-21.21~22.04.1",
            "linux-modules-ivsc-generic-hwe-22.04": "6.5.0.21.21~22.04.11",
            "linux-headers-generic-64k-hwe-22.04": "6.5.0.21.21~22.04.11",
            "linux-modules-6.5.0-21-generic": "6.5.0-21.21~22.04.1",
            "linux-hwe-6.5-cloud-tools-common": "6.5.0-21.21~22.04.1",
            "linux-cloud-tools-6.5.0-21-generic": "6.5.0-21.21~22.04.1",
            "linux-hwe-6.5-tools-common": "6.5.0-21.21~22.04.1",
            "linux-image-6.5.0-21-generic": "6.5.0-21.21~22.04.1",
            "linux-modules-6.5.0-21-generic-64k": "6.5.0-21.21~22.04.1",
            "linux-image-generic-hwe-22.04": "6.5.0.21.21~22.04.11",
            "linux-image-generic-64k-hwe-22.04-edge": "6.5.0.21.21~22.04.11",
            "linux-cloud-tools-virtual-hwe-22.04-edge": "6.5.0.21.21~22.04.11",
            "linux-virtual-hwe-22.04-edge": "6.5.0.21.21~22.04.11",
            "linux-image-unsigned-6.5.0-21-generic": "6.5.0-21.21~22.04.1",
            "linux-headers-6.5.0-21-generic-64k": "6.5.0-21.21~22.04.1",
            "linux-image-uc-6.5.0-21-generic": "6.5.0-21.21~22.04.1",
            "linux-tools-6.5.0-21-generic-64k": "6.5.0-21.21~22.04.1",
            "linux-modules-ipu6-6.5.0-21-generic": "6.5.0-21.21~22.04.1",
            "linux-image-virtual-hwe-22.04-edge": "6.5.0.21.21~22.04.11",
            "linux-cloud-tools-generic-hwe-22.04": "6.5.0.21.21~22.04.11",
            "linux-modules-iwlwifi-generic-hwe-22.04-edge": "6.5.0.21.21~22.04.11",
            "linux-virtual-hwe-22.04": "6.5.0.21.21~22.04.11",
            "linux-source-6.5.0": "6.5.0-21.21~22.04.1",
            "linux-image-generic-64k-hwe-22.04": "6.5.0.21.21~22.04.11",
            "linux-image-6.5.0-21-generic-64k": "6.5.0-21.21~22.04.1",
            "linux-modules-ipu6-generic-hwe-22.04-edge": "6.5.0.21.21~22.04.11",
            "linux-tools-virtual-hwe-22.04": "6.5.0.21.21~22.04.11",
            "linux-modules-ivsc-generic-hwe-22.04-edge": "6.5.0.21.21~22.04.11",
            "linux-modules-iwlwifi-6.5.0-21-generic": "6.5.0-21.21~22.04.1",
            "linux-image-extra-virtual-hwe-22.04-edge": "6.5.0.21.21~22.04.11",
            "linux-buildinfo-6.5.0-21-generic": "6.5.0-21.21~22.04.1",
            "linux-tools-virtual-hwe-22.04-edge": "6.5.0.21.21~22.04.11",
            "linux-generic-64k-hwe-22.04": "6.5.0.21.21~22.04.11",
            "linux-modules-ipu6-generic-hwe-22.04": "6.5.0.21.21~22.04.11",
            "linux-headers-generic-64k-hwe-22.04-edge": "6.5.0.21.21~22.04.11",
            "linux-generic-hwe-22.04-edge": "6.5.0.21.21~22.04.11",
            "linux-generic-hwe-22.04": "6.5.0.21.21~22.04.11",
            "linux-image-unsigned-6.5.0-21-generic-64k": "6.5.0-21.21~22.04.1",
            "linux-tools-generic-hwe-22.04": "6.5.0.21.21~22.04.11",
            "linux-hwe-6.5-cloud-tools-6.5.0-21": "6.5.0-21.21~22.04.1",
            "linux-image-uc-generic-hwe-22.04": "6.5.0.21.21~22.04.11",
            "linux-buildinfo-6.5.0-21-generic-64k": "6.5.0-21.21~22.04.1",
            "linux-tools-6.5.0-21-generic": "6.5.0-21.21~22.04.1",
            "linux-cloud-tools-generic-hwe-22.04-edge": "6.5.0.21.21~22.04.11",
            "linux-headers-generic-hwe-22.04": "6.5.0.21.21~22.04.11",
            "linux-cloud-tools-virtual-hwe-22.04": "6.5.0.21.21~22.04.11",
            "linux-image-extra-virtual-hwe-22.04": "6.5.0.21.21~22.04.11"
        }
    ]
}

Ubuntu:23.10 / linux

Package

Name
linux

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
6.5.0-21.21

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-tools-oem-20.04c": "6.5.0.21.20",
            "linux-tools-generic-64k-hwe-22.04": "6.5.0.21.20",
            "linux-headers-virtual-hwe-22.04-edge": "6.5.0.21.20",
            "linux-headers-generic-hwe-22.04-edge": "6.5.0.21.20",
            "linux-headers-oem-20.04b": "6.5.0.21.20",
            "linux-modules-iwlwifi-oem-22.04": "6.5.0.21.20",
            "linux-image-uc-6.5.0-21-generic-64k": "6.5.0-21.21",
            "linux-headers-6.5.0-21-generic": "6.5.0-21.21",
            "linux-tools-virtual": "6.5.0.21.20",
            "linux-source": "6.5.0.21.20",
            "linux-oem-20.04d": "6.5.0.21.20",
            "linux-cloud-tools-generic": "6.5.0.21.20",
            "linux-image-virtual": "6.5.0.21.20",
            "linux-tools-generic": "6.5.0.21.20",
            "linux-generic-64k-hwe-22.04-edge": "6.5.0.21.20",
            "linux-image-generic-hwe-22.04-edge": "6.5.0.21.20",
            "linux-virtual": "6.5.0.21.20",
            "linux-image-oem-20.04d": "6.5.0.21.20",
            "linux-modules-iwlwifi-generic-hwe-22.04": "6.5.0.21.20",
            "linux-modules-extra-6.5.0-21-generic": "6.5.0-21.21",
            "linux-crashdump": "6.5.0.21.20",
            "linux-tools-oem-20.04d": "6.5.0.21.20",
            "linux-generic": "6.5.0.21.20",
            "linux-modules-ipu6-generic": "6.5.0.21.20",
            "linux-modules-6.5.0-21-generic": "6.5.0-21.21",
            "linux-cloud-tools-6.5.0-21-generic": "6.5.0-21.21",
            "linux-headers-6.5.0-21": "6.5.0-21.21",
            "linux-generic-64k": "6.5.0.21.20",
            "linux-image-generic-hwe-22.04": "6.5.0.21.20",
            "linux-image-generic-64k-hwe-22.04-edge": "6.5.0.21.20",
            "linux-lib-rust-6.5.0-21-generic": "6.5.0-21.21",
            "linux-image-generic-lpae": "6.5.0.21.20",
            "linux-tools-6.5.0-21-generic-64k": "6.5.0-21.21",
            "linux-modules-ipu6-6.5.0-21-generic": "6.5.0-21.21",
            "linux-cloud-tools-common": "6.5.0-21.21",
            "linux-image-virtual-hwe-22.04-edge": "6.5.0.21.20",
            "linux-headers-generic-64k": "6.5.0.21.20",
            "linux-libc-dev": "6.5.0-21.21",
            "linux-headers-oem-20.04c": "6.5.0.21.20",
            "linux-image-oem-20.04": "6.5.0.21.20",
            "linux-virtual-hwe-22.04": "6.5.0.21.20",
            "linux-modules-ipu6-oem-22.04": "6.5.0.21.20",
            "linux-image-kvm": "6.5.0.21.20",
            "linux-image-generic-64k-hwe-22.04": "6.5.0.21.20",
            "linux-tools-oem-20.04": "6.5.0.21.20",
            "linux-tools-virtual-hwe-22.04": "6.5.0.21.20",
            "linux-modules-ivsc-generic-hwe-22.04-edge": "6.5.0.21.20",
            "linux-modules-iwlwifi-6.5.0-21-generic": "6.5.0-21.21",
            "linux-headers-virtual": "6.5.0.21.20",
            "linux-image-extra-virtual-hwe-22.04-edge": "6.5.0.21.20",
            "linux-buildinfo-6.5.0-21-generic": "6.5.0-21.21",
            "linux-generic-hwe-22.04-edge": "6.5.0.21.20",
            "linux-image-unsigned-6.5.0-21-generic-64k": "6.5.0-21.21",
            "linux-oem-20.04": "6.5.0.21.20",
            "linux-tools-common": "6.5.0-21.21",
            "linux-image-generic": "6.5.0.21.20",
            "linux-cloud-tools-generic-hwe-22.04-edge": "6.5.0.21.20",
            "linux-headers-generic-hwe-22.04": "6.5.0.21.20",
            "linux-image-extra-virtual-hwe-22.04": "6.5.0.21.20",
            "linux-tools-oem-22.04": "6.5.0.21.20",
            "linux-oem-20.04c": "6.5.0.21.20",
            "linux-modules-ivsc-generic": "6.5.0.21.20",
            "linux-cloud-tools-virtual": "6.5.0.21.20",
            "linux-modules-iwlwifi-oem-20.04d": "6.5.0.21.20",
            "linux-modules-ivsc-6.5.0-21-generic": "6.5.0-21.21",
            "linux-image-extra-virtual": "6.5.0.21.20",
            "linux-tools-generic-hwe-22.04-edge": "6.5.0.21.20",
            "linux-generic-lpae": "6.5.0.21.20",
            "linux-headers-virtual-hwe-22.04": "6.5.0.21.20",
            "linux-image-uc-generic-hwe-22.04-edge": "6.5.0.21.20",
            "linux-image-virtual-hwe-22.04": "6.5.0.21.20",
            "linux-oem-20.04b": "6.5.0.21.20",
            "linux-tools-generic-64k-hwe-22.04-edge": "6.5.0.21.20",
            "linux-tools-generic-64k": "6.5.0.21.20",
            "linux-modules-ivsc-generic-hwe-22.04": "6.5.0.21.20",
            "linux-image-oem-20.04c": "6.5.0.21.20",
            "linux-headers-generic-64k-hwe-22.04": "6.5.0.21.20",
            "linux-image-6.5.0-21-generic": "6.5.0-21.21",
            "linux-tools-6.5.0-21": "6.5.0-21.21",
            "linux-virtual-hwe-22.04-edge": "6.5.0.21.20",
            "linux-cloud-tools-virtual-hwe-22.04-edge": "6.5.0.21.20",
            "linux-headers-6.5.0-21-generic-64k": "6.5.0-21.21",
            "linux-modules-6.5.0-21-generic-64k": "6.5.0-21.21",
            "linux-headers-generic-lpae": "6.5.0.21.20",
            "linux-image-unsigned-6.5.0-21-generic": "6.5.0-21.21",
            "linux-image-uc-6.5.0-21-generic": "6.5.0-21.21",
            "linux-headers-kvm": "6.5.0.21.20",
            "linux-kvm": "6.5.0.21.20",
            "linux-cloud-tools-generic-hwe-22.04": "6.5.0.21.20",
            "linux-modules-iwlwifi-generic-hwe-22.04-edge": "6.5.0.21.20",
            "linux-doc": "6.5.0-21.21",
            "linux-source-6.5.0": "6.5.0-21.21",
            "linux-image-generic-64k": "6.5.0.21.20",
            "linux-image-6.5.0-21-generic-64k": "6.5.0-21.21",
            "linux-modules-ipu6-generic-hwe-22.04-edge": "6.5.0.21.20",
            "linux-image-uc-generic": "6.5.0.21.20",
            "linux-headers-generic": "6.5.0.21.20",
            "linux-tools-kvm": "6.5.0.21.20",
            "linux-cloud-tools-6.5.0-21": "6.5.0-21.21",
            "linux-modules-iwlwifi-generic": "6.5.0.21.20",
            "linux-modules-iwlwifi-oem-20.04": "6.5.0.21.20",
            "linux-modules-ivsc-oem-22.04": "6.5.0.21.20",
            "linux-tools-host": "6.5.0-21.21",
            "linux-image-oem-22.04": "6.5.0.21.20",
            "linux-tools-virtual-hwe-22.04-edge": "6.5.0.21.20",
            "linux-generic-64k-hwe-22.04": "6.5.0.21.20",
            "linux-modules-ipu6-generic-hwe-22.04": "6.5.0.21.20",
            "linux-headers-generic-64k-hwe-22.04-edge": "6.5.0.21.20",
            "linux-tools-generic-lpae": "6.5.0.21.20",
            "linux-generic-hwe-22.04": "6.5.0.21.20",
            "linux-tools-generic-hwe-22.04": "6.5.0.21.20",
            "linux-headers-oem-22.04": "6.5.0.21.20",
            "linux-headers-oem-20.04": "6.5.0.21.20",
            "linux-image-uc-generic-hwe-22.04": "6.5.0.21.20",
            "linux-image-oem-20.04b": "6.5.0.21.20",
            "linux-headers-oem-20.04d": "6.5.0.21.20",
            "linux-tools-oem-20.04b": "6.5.0.21.20",
            "linux-buildinfo-6.5.0-21-generic-64k": "6.5.0-21.21",
            "linux-oem-22.04": "6.5.0.21.20",
            "linux-cloud-tools-virtual-hwe-22.04": "6.5.0.21.20",
            "linux-tools-6.5.0-21-generic": "6.5.0-21.21"
        }
    ]
}

Ubuntu:23.10 / linux-aws

Package

Name
linux-aws

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
6.5.0-1014.14

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-unsigned-6.5.0-1014-aws": "6.5.0-1014.14",
            "linux-aws-headers-6.5.0-1014": "6.5.0-1014.14",
            "linux-tools-6.5.0-1014-aws": "6.5.0-1014.14",
            "linux-cloud-tools-6.5.0-1014-aws": "6.5.0-1014.14",
            "linux-headers-aws": "6.5.0.1014.14",
            "linux-image-6.5.0-1014-aws": "6.5.0-1014.14",
            "linux-modules-extra-6.5.0-1014-aws": "6.5.0-1014.14",
            "linux-buildinfo-6.5.0-1014-aws": "6.5.0-1014.14",
            "linux-aws": "6.5.0.1014.14",
            "linux-image-aws": "6.5.0.1014.14",
            "linux-aws-cloud-tools-6.5.0-1014": "6.5.0-1014.14",
            "linux-modules-6.5.0-1014-aws": "6.5.0-1014.14",
            "linux-modules-extra-aws": "6.5.0.1014.14",
            "linux-aws-tools-6.5.0-1014": "6.5.0-1014.14",
            "linux-headers-6.5.0-1014-aws": "6.5.0-1014.14",
            "linux-tools-aws": "6.5.0.1014.14"
        }
    ]
}

Ubuntu:23.10 / linux-gcp

Package

Name
linux-gcp

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
6.5.0-1014.14

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-unsigned-6.5.0-1014-gcp": "6.5.0-1014.14",
            "linux-gcp-tools-6.5.0-1014": "6.5.0-1014.14",
            "linux-tools-gcp": "6.5.0.1014.14",
            "linux-modules-iwlwifi-gcp": "6.5.0.1014.14",
            "linux-modules-extra-6.5.0-1014-gcp": "6.5.0-1014.14",
            "linux-gcp": "6.5.0.1014.14",
            "linux-headers-6.5.0-1014-gcp": "6.5.0-1014.14",
            "linux-image-6.5.0-1014-gcp": "6.5.0-1014.14",
            "linux-gcp-headers-6.5.0-1014": "6.5.0-1014.14",
            "linux-headers-gcp": "6.5.0.1014.14",
            "linux-tools-6.5.0-1014-gcp": "6.5.0-1014.14",
            "linux-modules-extra-gcp": "6.5.0.1014.14",
            "linux-image-gcp": "6.5.0.1014.14",
            "linux-modules-6.5.0-1014-gcp": "6.5.0-1014.14",
            "linux-modules-iwlwifi-6.5.0-1014-gcp": "6.5.0-1014.14",
            "linux-buildinfo-6.5.0-1014-gcp": "6.5.0-1014.14"
        }
    ]
}

Ubuntu:23.10 / linux-laptop

Package

Name
linux-laptop

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
6.5.0-1010.13

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-modules-6.5.0-1010-laptop": "6.5.0-1010.13",
            "linux-laptop-23.10": "6.5.0.1010.13",
            "linux-headers-6.5.0-1010-laptop": "6.5.0-1010.13",
            "linux-image-laptop-23.10": "6.5.0.1010.13",
            "linux-buildinfo-6.5.0-1010-laptop": "6.5.0-1010.13",
            "linux-headers-laptop-23.10": "6.5.0.1010.13",
            "linux-tools-6.5.0-1010-laptop": "6.5.0-1010.13",
            "linux-tools-laptop-23.10": "6.5.0.1010.13",
            "linux-laptop-tools-6.5.0-1010": "6.5.0-1010.13",
            "linux-laptop-headers-6.5.0-1010": "6.5.0-1010.13",
            "linux-image-6.5.0-1010-laptop": "6.5.0-1010.13"
        }
    ]
}

Ubuntu:23.10 / linux-oracle

Package

Name
linux-oracle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
6.5.0-1016.16

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-tools-oracle": "6.5.0.1016.16",
            "linux-buildinfo-6.5.0-1016-oracle": "6.5.0-1016.16",
            "linux-image-unsigned-6.5.0-1016-oracle": "6.5.0-1016.16",
            "linux-tools-6.5.0-1016-oracle": "6.5.0-1016.16",
            "linux-modules-6.5.0-1016-oracle": "6.5.0-1016.16",
            "linux-headers-6.5.0-1016-oracle": "6.5.0-1016.16",
            "linux-oracle-tools-6.5.0-1016": "6.5.0-1016.16",
            "linux-oracle": "6.5.0.1016.16",
            "linux-modules-iwlwifi-oracle": "6.5.0.1016.16",
            "linux-modules-iwlwifi-6.5.0-1016-oracle": "6.5.0-1016.16",
            "linux-headers-oracle": "6.5.0.1016.16",
            "linux-oracle-headers-6.5.0-1016": "6.5.0-1016.16",
            "linux-modules-extra-6.5.0-1016-oracle": "6.5.0-1016.16",
            "linux-image-oracle": "6.5.0.1016.16",
            "linux-image-6.5.0-1016-oracle": "6.5.0-1016.16"
        }
    ]
}

Ubuntu:23.10 / linux-raspi

Package

Name
linux-raspi

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
6.5.0-1011.14

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-raspi-tools-6.5.0-1011": "6.5.0-1011.14",
            "linux-raspi-headers-6.5.0-1011": "6.5.0-1011.14",
            "linux-headers-raspi-nolpae": "6.5.0.1011.12",
            "linux-headers-6.5.0-1011-raspi": "6.5.0-1011.14",
            "linux-raspi-nolpae": "6.5.0.1011.12",
            "linux-headers-raspi": "6.5.0.1011.12",
            "linux-modules-extra-raspi-nolpae": "6.5.0.1011.12",
            "linux-modules-6.5.0-1011-raspi": "6.5.0-1011.14",
            "linux-tools-raspi": "6.5.0.1011.12",
            "linux-modules-extra-6.5.0-1011-raspi": "6.5.0-1011.14",
            "linux-raspi": "6.5.0.1011.12",
            "linux-tools-6.5.0-1011-raspi": "6.5.0-1011.14",
            "linux-image-raspi-nolpae": "6.5.0.1011.12",
            "linux-modules-extra-raspi": "6.5.0.1011.12",
            "linux-image-raspi": "6.5.0.1011.12",
            "linux-buildinfo-6.5.0-1011-raspi": "6.5.0-1011.14",
            "linux-tools-raspi-nolpae": "6.5.0.1011.12",
            "linux-image-6.5.0-1011-raspi": "6.5.0-1011.14"
        }
    ]
}

Ubuntu:23.10 / linux-starfive

Package

Name
linux-starfive

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
6.5.0-1008.9

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-6.5.0-1008-starfive": "6.5.0-1008.9",
            "linux-headers-starfive": "6.5.0.1008.10",
            "linux-tools-6.5.0-1008-starfive": "6.5.0-1008.9",
            "linux-starfive-headers-6.5.0-1008": "6.5.0-1008.9",
            "linux-tools-starfive": "6.5.0.1008.10",
            "linux-headers-6.5.0-1008-starfive": "6.5.0-1008.9",
            "linux-starfive-tools-6.5.0-1008": "6.5.0-1008.9",
            "linux-starfive": "6.5.0.1008.10",
            "linux-modules-6.5.0-1008-starfive": "6.5.0-1008.9",
            "linux-image-starfive": "6.5.0.1008.10",
            "linux-modules-extra-6.5.0-1008-starfive": "6.5.0-1008.9",
            "linux-buildinfo-6.5.0-1008-starfive": "6.5.0-1008.9"
        }
    ]
}