USN-6657-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6657-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6657-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6657-1
Related
Published
2024-02-26T13:52:13.956982Z
Modified
2024-02-26T13:52:13.956982Z
Summary
dnsmasq vulnerabilities
Details

Elias Heftrig, Haya Schulmann, Niklas Vogel, and Michael Waidner discovered that Dnsmasq icorrectly handled validating DNSSEC messages. A remote attacker could possibly use this issue to cause Dnsmasq to consume resources, leading to a denial of service. (CVE-2023-50387)

It was discovered that Dnsmasq incorrectly handled preparing an NSEC3 closest encloser proof. A remote attacker could possibly use this issue to cause Dnsmasq to consume resources, leading to a denial of service. (CVE-2023-50868)

It was discovered that Dnsmasq incorrectly set the maximum EDNS.0 UDP packet size as required by DNS Flag Day 2020. This issue only affected Ubuntu 23.10. (CVE-2023-28450)

References

Affected packages

Ubuntu:20.04:LTS / dnsmasq

Package

Name
dnsmasq

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.90-0ubuntu0.20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "dnsmasq": "2.90-0ubuntu0.20.04.1",
            "dnsmasq-base-lua": "2.90-0ubuntu0.20.04.1",
            "dnsmasq-utils": "2.90-0ubuntu0.20.04.1",
            "dnsmasq-base": "2.90-0ubuntu0.20.04.1"
        }
    ]
}

Ubuntu:22.04:LTS / dnsmasq

Package

Name
dnsmasq

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.90-0ubuntu0.22.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "dnsmasq": "2.90-0ubuntu0.22.04.1",
            "dnsmasq-base-lua": "2.90-0ubuntu0.22.04.1",
            "dnsmasq-utils": "2.90-0ubuntu0.22.04.1",
            "dnsmasq-base": "2.90-0ubuntu0.22.04.1"
        }
    ]
}

Ubuntu:23.10 / dnsmasq

Package

Name
dnsmasq

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.90-0ubuntu0.23.10.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "dnsmasq": "2.90-0ubuntu0.23.10.1",
            "dnsmasq-base-lua": "2.90-0ubuntu0.23.10.1",
            "dnsmasq-utils": "2.90-0ubuntu0.23.10.1",
            "dnsmasq-base": "2.90-0ubuntu0.23.10.1"
        }
    ]
}