USN-6667-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6667-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6667-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6667-1
Related
Published
2024-02-28T13:27:00.924851Z
Modified
2024-02-28T13:27:00.924851Z
Summary
libcpanel-json-xs-perl vulnerability
Details

It was discovered that Cpanel-JSON-XS incorrectly decoded certain data. A remote attacker could use this issue to cause Cpanel-JSON-XS to crash, resulting in a denial of service, or possibly obtain sensitive information.

References

Affected packages

Ubuntu:20.04:LTS / libcpanel-json-xs-perl

Package

Name
libcpanel-json-xs-perl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.19-1ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libcpanel-json-xs-perl": "4.19-1ubuntu0.1"
        }
    ]
}

Ubuntu:22.04:LTS / libcpanel-json-xs-perl

Package

Name
libcpanel-json-xs-perl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.27-1ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libcpanel-json-xs-perl": "4.27-1ubuntu0.1"
        }
    ]
}