USN-6671-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6671-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6671-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6671-1
Related
Published
2024-02-29T16:02:17.308463Z
Modified
2024-02-29T16:02:17.308463Z
Summary
php-nyholm-psr7 vulnerability
Details

It was discovered that php-nyholm-psr7 incorrectly parsed HTTP headers. A remote attacker could possibly use this issue to perform an HTTP header injection attack.

References

Affected packages

Ubuntu:Pro:22.04:LTS / php-nyholm-psr7

Package

Name
php-nyholm-psr7

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.5.0-1ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "php-nyholm-psr7": "1.5.0-1ubuntu0.1~esm1"
        }
    ]
}