USN-6685-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6685-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6685-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6685-1
Related
Published
2024-03-07T21:18:06.948734Z
Modified
2024-03-07T21:18:06.948734Z
Summary
mqtt-client vulnerability
Details

It was discovered that mqtt-client incorrectly handled memory while parsing malformed MQTT frames. An attacker could possibly use this issue to cause a crash, resulting in a denial of service, or possibly execute arbitrary code.

References

Affected packages

Ubuntu:Pro:18.04:LTS / mqtt-client

Package

Name
mqtt-client

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.14-1ubuntu0.18.04.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libmqtt-client-java": "1.14-1ubuntu0.18.04.1~esm1"
        }
    ]
}

Ubuntu:20.04:LTS / mqtt-client

Package

Name
mqtt-client

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.14-1+deb10u1build0.20.04.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libmqtt-client-java": "1.14-1+deb10u1build0.20.04.1"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / mqtt-client

Package

Name
mqtt-client

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.10-1ubuntu0.1~esm1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "libmqtt-client-java": "1.10-1ubuntu0.1~esm1"
        }
    ]
}