USN-6687-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6687-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6687-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6687-1
Related
Published
2024-03-11T12:34:46.003311Z
Modified
2024-03-11T12:34:46.003311Z
Summary
accountsservice vulnerability
Details

It was discovered that AccountsService called a helper incorrectly when performing password change operations. A local attacker could possibly use this issue to obtain encrypted passwords.

References

Affected packages

Ubuntu:20.04:LTS / accountsservice

Package

Name
accountsservice

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.6.55-0ubuntu12~20.04.7

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libaccountsservice-doc": "0.6.55-0ubuntu12~20.04.7",
            "libaccountsservice-dev": "0.6.55-0ubuntu12~20.04.7",
            "libaccountsservice0": "0.6.55-0ubuntu12~20.04.7",
            "accountsservice": "0.6.55-0ubuntu12~20.04.7",
            "gir1.2-accountsservice-1.0": "0.6.55-0ubuntu12~20.04.7"
        }
    ]
}

Ubuntu:22.04:LTS / accountsservice

Package

Name
accountsservice

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
22.07.5-2ubuntu1.5

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libaccountsservice-doc": "22.07.5-2ubuntu1.5",
            "libaccountsservice-dev": "22.07.5-2ubuntu1.5",
            "libaccountsservice0": "22.07.5-2ubuntu1.5",
            "accountsservice": "22.07.5-2ubuntu1.5",
            "gir1.2-accountsservice-1.0": "22.07.5-2ubuntu1.5"
        }
    ]
}