USN-6694-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6694-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6694-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6694-1
Related
Published
2024-03-14T10:19:40.430402Z
Modified
2024-03-14T10:19:40.430402Z
Summary
expat vulnerabilities
Details

It was discovered that Expat could be made to consume large amounts of resources. If a user or automated system were tricked into processing specially crafted input, an attacker could possibly use this issue to cause a denial of service. (CVE-2023-52425, CVE-2024-28757)

References

Affected packages

Ubuntu:22.04:LTS / expat

Package

Name
expat

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.4.7-1ubuntu0.3

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libexpat1-dev": "2.4.7-1ubuntu0.3",
            "expat": "2.4.7-1ubuntu0.3",
            "libexpat1": "2.4.7-1ubuntu0.3"
        }
    ]
}

Ubuntu:23.10 / expat

Package

Name
expat

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.5.0-2ubuntu0.1

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "libexpat1-dev": "2.5.0-2ubuntu0.1",
            "expat": "2.5.0-2ubuntu0.1",
            "libexpat1": "2.5.0-2ubuntu0.1"
        }
    ]
}