USN-6700-1

See a problem?
Source
https://ubuntu.com/security/notices/USN-6700-1
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6700-1.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6700-1
Related
Published
2024-03-18T23:57:25.414970Z
Modified
2024-03-18T23:57:25.414970Z
Summary
linux, linux-aws, linux-kvm, linux-lts-xenial vulnerabilities
Details

It was discovered that the Layer 2 Tunneling Protocol (L2TP) implementation in the Linux kernel contained a race condition when releasing PPPoL2TP sockets in certain conditions, leading to a use-after-free vulnerability. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2022-20567)

It was discovered that the ext4 file system implementation in the Linux kernel did not properly handle block device modification while it is mounted. A privileged attacker could use this to cause a denial of service (system crash) or possibly expose sensitive information. (CVE-2023-34256)

Eric Dumazet discovered that the netfilter subsystem in the Linux kernel did not properly handle DCCP conntrack buffers in certain situations, leading to an out-of-bounds read vulnerability. An attacker could possibly use this to expose sensitive information (kernel memory). (CVE-2023-39197)

It was discovered that a race condition existed in the AppleTalk networking subsystem of the Linux kernel, leading to a use-after-free vulnerability. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2023-51781)

It was discovered that the ext4 file system implementation in the Linux kernel did not properly handle the remount operation in certain cases, leading to a use-after-free vulnerability. A local attacker could use this to cause a denial of service (system crash) or possibly expose sensitive information. (CVE-2024-0775)

Notselwyn discovered that the netfilter subsystem in the Linux kernel did not properly handle verdict parameters in certain cases, leading to a use- after-free vulnerability. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2024-1086)

It was discovered that a race condition existed in the SCSI Emulex LightPulse Fibre Channel driver in the Linux kernel when unregistering FCF and re-scanning an HBA FCF table, leading to a null pointer dereference vulnerability. A local attacker could use this to cause a denial of service (system crash). (CVE-2024-24855)

References

Affected packages

Ubuntu:Pro:14.04:LTS / linux-aws

Package

Name
linux-aws

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.4.0-1129.135

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "linux-buildinfo-4.4.0-1129-aws": "4.4.0-1129.135",
            "linux-tools-4.4.0-1129-aws": "4.4.0-1129.135",
            "linux-aws-headers-4.4.0-1129": "4.4.0-1129.135",
            "linux-cloud-tools-4.4.0-1129-aws": "4.4.0-1129.135",
            "linux-image-4.4.0-1129-aws": "4.4.0-1129.135",
            "linux-aws-cloud-tools-4.4.0-1129": "4.4.0-1129.135",
            "linux-headers-aws": "4.4.0.1129.126",
            "linux-headers-4.4.0-1129-aws": "4.4.0-1129.135",
            "linux-aws-tools-4.4.0-1129": "4.4.0-1129.135",
            "linux-modules-4.4.0-1129-aws": "4.4.0-1129.135",
            "linux-aws": "4.4.0.1129.126",
            "linux-image-aws": "4.4.0.1129.126",
            "linux-tools-aws": "4.4.0.1129.126"
        }
    ]
}

Ubuntu:Pro:14.04:LTS / linux-lts-xenial

Package

Name
linux-lts-xenial

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.4.0-252.286~14.04.1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "linux-cloud-tools-4.4.0-252-lowlatency": "4.4.0-252.286~14.04.1",
            "linux-headers-4.4.0-252-lowlatency": "4.4.0-252.286~14.04.1",
            "linux-signed-lowlatency-lts-xenial": "4.4.0.252.219",
            "linux-tools-4.4.0-252-lowlatency": "4.4.0-252.286~14.04.1",
            "linux-cloud-tools-4.4.0-252-generic": "4.4.0-252.286~14.04.1",
            "linux-cloud-tools-lowlatency-lts-xenial": "4.4.0.252.219",
            "linux-image-virtual-lts-xenial": "4.4.0.252.219",
            "linux-modules-extra-4.4.0-252-generic": "4.4.0-252.286~14.04.1",
            "linux-generic-lts-xenial": "4.4.0.252.219",
            "linux-modules-4.4.0-252-generic": "4.4.0-252.286~14.04.1",
            "linux-lts-xenial-cloud-tools-4.4.0-252": "4.4.0-252.286~14.04.1",
            "linux-image-4.4.0-252-lowlatency": "4.4.0-252.286~14.04.1",
            "linux-buildinfo-4.4.0-252-generic": "4.4.0-252.286~14.04.1",
            "linux-image-unsigned-4.4.0-252-generic": "4.4.0-252.286~14.04.1",
            "linux-image-generic-lts-xenial": "4.4.0.252.219",
            "linux-image-unsigned-4.4.0-252-lowlatency": "4.4.0-252.286~14.04.1",
            "linux-image-4.4.0-252-generic": "4.4.0-252.286~14.04.1",
            "linux-image-extra-virtual-lts-xenial": "4.4.0.252.219",
            "linux-tools-generic-lts-xenial": "4.4.0.252.219",
            "linux-virtual-lts-xenial": "4.4.0.252.219",
            "linux-headers-4.4.0-252": "4.4.0-252.286~14.04.1",
            "linux-headers-virtual-lts-xenial": "4.4.0.252.219",
            "linux-signed-generic-lts-xenial": "4.4.0.252.219",
            "linux-cloud-tools-generic-lts-xenial": "4.4.0.252.219",
            "linux-headers-generic-lts-xenial": "4.4.0.252.219",
            "linux-image-lowlatency-lts-xenial": "4.4.0.252.219",
            "linux-lowlatency-lts-xenial": "4.4.0.252.219",
            "linux-lts-xenial-tools-4.4.0-252": "4.4.0-252.286~14.04.1",
            "linux-buildinfo-4.4.0-252-lowlatency": "4.4.0-252.286~14.04.1",
            "linux-cloud-tools-virtual-lts-xenial": "4.4.0.252.219",
            "linux-modules-4.4.0-252-lowlatency": "4.4.0-252.286~14.04.1",
            "linux-signed-image-generic-lts-xenial": "4.4.0.252.219",
            "linux-headers-4.4.0-252-generic": "4.4.0-252.286~14.04.1",
            "linux-signed-image-lowlatency-lts-xenial": "4.4.0.252.219",
            "linux-tools-lowlatency-lts-xenial": "4.4.0.252.219",
            "linux-tools-virtual-lts-xenial": "4.4.0.252.219",
            "linux-tools-4.4.0-252-generic": "4.4.0-252.286~14.04.1",
            "linux-headers-lowlatency-lts-xenial": "4.4.0.252.219"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / linux

Package

Name
linux

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.4.0-252.286

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "linux-tools-generic-lts-wily": "4.4.0.252.258",
            "linux-tools-virtual-lts-vivid": "4.4.0.252.258",
            "linux-headers-generic-lts-wily": "4.4.0.252.258",
            "linux-source-4.4.0": "4.4.0-252.286",
            "linux-cloud-tools-virtual-lts-wily": "4.4.0.252.258",
            "linux-cloud-tools-lowlatency-lts-xenial": "4.4.0.252.258",
            "linux-image-extra-virtual-lts-utopic": "4.4.0.252.258",
            "linux-generic-lts-utopic": "4.4.0.252.258",
            "linux-tools-virtual": "4.4.0.252.258",
            "linux-buildinfo-4.4.0-252-generic": "4.4.0-252.286",
            "linux-signed-image-lowlatency": "4.4.0.252.258",
            "linux-image-unsigned-4.4.0-252-lowlatency": "4.4.0-252.286",
            "linux-source": "4.4.0.252.258",
            "linux-cloud-tools-generic": "4.4.0.252.258",
            "linux-image-virtual": "4.4.0.252.258",
            "linux-headers-virtual-lts-utopic": "4.4.0.252.258",
            "linux-signed-image-generic-lts-wily": "4.4.0.252.258",
            "linux-tools-generic": "4.4.0.252.258",
            "linux-image-generic-lts-vivid": "4.4.0.252.258",
            "linux-virtual": "4.4.0.252.258",
            "linux-virtual-lts-utopic": "4.4.0.252.258",
            "linux-crashdump": "4.4.0.252.258",
            "linux-generic-lts-vivid": "4.4.0.252.258",
            "linux-image-lowlatency-lts-xenial": "4.4.0.252.258",
            "linux-generic": "4.4.0.252.258",
            "linux-headers-lowlatency-lts-utopic": "4.4.0.252.258",
            "linux-cloud-tools-lowlatency-lts-wily": "4.4.0.252.258",
            "linux-image-generic-lts-wily": "4.4.0.252.258",
            "linux-cloud-tools-4.4.0-252-lowlatency": "4.4.0-252.286",
            "linux-tools-lowlatency": "4.4.0.252.258",
            "linux-image-virtual-lts-vivid": "4.4.0.252.258",
            "linux-image-hwe-virtual-trusty": "4.4.0.252.258",
            "linux-cloud-tools-common": "4.4.0-252.286",
            "linux-signed-image-generic": "4.4.0.252.258",
            "linux-libc-dev": "4.4.0-252.286",
            "linux-image-virtual-lts-xenial": "4.4.0.252.258",
            "linux-tools-lowlatency-lts-wily": "4.4.0.252.258",
            "linux-image-4.4.0-252-lowlatency": "4.4.0-252.286",
            "linux-image-unsigned-4.4.0-252-generic": "4.4.0-252.286",
            "linux-image-4.4.0-252-generic": "4.4.0-252.286",
            "linux-image-generic-lts-xenial": "4.4.0.252.258",
            "linux-headers-virtual": "4.4.0.252.258",
            "linux-hwe-generic-trusty": "4.4.0.252.258",
            "linux-image-generic-lts-utopic": "4.4.0.252.258",
            "linux-virtual-lts-xenial": "4.4.0.252.258",
            "linux-tools-generic-lts-vivid": "4.4.0.252.258",
            "linux-headers-virtual-lts-xenial": "4.4.0.252.258",
            "linux-headers-virtual-lts-vivid": "4.4.0.252.258",
            "linux-generic-lts-wily": "4.4.0.252.258",
            "linux-tools-lts-utopic": "4.4.0.252.258",
            "linux-signed-lowlatency": "4.4.0.252.258",
            "linux-lowlatency-lts-vivid": "4.4.0.252.258",
            "linux-tools-4.4.0-252": "4.4.0-252.286",
            "linux-cloud-tools-virtual-lts-xenial": "4.4.0.252.258",
            "linux-signed-image-generic-lts-xenial": "4.4.0.252.258",
            "linux-lowlatency-lts-utopic": "4.4.0.252.258",
            "linux-signed-image-lowlatency-lts-xenial": "4.4.0.252.258",
            "linux-cloud-tools-virtual-lts-utopic": "4.4.0.252.258",
            "linux-image-extra-virtual-lts-vivid": "4.4.0.252.258",
            "linux-image-generic": "4.4.0.252.258",
            "linux-headers-generic-lts-vivid": "4.4.0.252.258",
            "linux-cloud-tools-lowlatency-lts-vivid": "4.4.0.252.258",
            "linux-tools-generic-lts-utopic": "4.4.0.252.258",
            "linux-headers-generic-lts-utopic": "4.4.0.252.258",
            "linux-lowlatency": "4.4.0.252.258",
            "linux-signed-generic-lts-vivid": "4.4.0.252.258",
            "linux-headers-4.4.0-252-lowlatency": "4.4.0-252.286",
            "linux-cloud-tools-generic-lts-wily": "4.4.0.252.258",
            "linux-image-lowlatency-lts-vivid": "4.4.0.252.258",
            "linux-signed-image-generic-lts-utopic": "4.4.0.252.258",
            "linux-image-hwe-generic-trusty": "4.4.0.252.258",
            "linux-tools-common": "4.4.0-252.286",
            "linux-tools-virtual-lts-wily": "4.4.0.252.258",
            "linux-lowlatency-lts-wily": "4.4.0.252.258",
            "linux-cloud-tools-4.4.0-252-generic": "4.4.0-252.286",
            "linux-cloud-tools-virtual": "4.4.0.252.258",
            "linux-image-virtual-lts-utopic": "4.4.0.252.258",
            "linux-cloud-tools-lowlatency": "4.4.0.252.258",
            "linux-modules-extra-4.4.0-252-generic": "4.4.0-252.286",
            "linux-tools-4.4.0-252-lowlatency": "4.4.0-252.286",
            "linux-cloud-tools-4.4.0-252": "4.4.0-252.286",
            "linux-cloud-tools-generic-lts-vivid": "4.4.0.252.258",
            "linux-cloud-tools-virtual-lts-vivid": "4.4.0.252.258",
            "linux-image-extra-virtual": "4.4.0.252.258",
            "linux-signed-image-lowlatency-lts-wily": "4.4.0.252.258",
            "linux-headers-lowlatency-lts-wily": "4.4.0.252.258",
            "linux-tools-generic-lts-xenial": "4.4.0.252.258",
            "linux-cloud-tools-lowlatency-lts-utopic": "4.4.0.252.258",
            "linux-signed-image-generic-lts-vivid": "4.4.0.252.258",
            "linux-buildinfo-4.4.0-252-lowlatency": "4.4.0-252.286",
            "linux-headers-generic-lts-xenial": "4.4.0.252.258",
            "linux-cloud-tools-generic-lts-xenial": "4.4.0.252.258",
            "linux-lowlatency-lts-xenial": "4.4.0.252.258",
            "linux-virtual-lts-vivid": "4.4.0.252.258",
            "linux-image-lowlatency-lts-utopic": "4.4.0.252.258",
            "linux-image-extra-virtual-lts-wily": "4.4.0.252.258",
            "linux-headers-lowlatency-lts-xenial": "4.4.0.252.258",
            "linux-signed-lowlatency-lts-wily": "4.4.0.252.258",
            "linux-signed-lowlatency-lts-xenial": "4.4.0.252.258",
            "linux-tools-lowlatency-lts-vivid": "4.4.0.252.258",
            "linux-image-lowlatency-lts-wily": "4.4.0.252.258",
            "linux-doc": "4.4.0-252.286",
            "linux-generic-lts-xenial": "4.4.0.252.258",
            "linux-headers-lowlatency-lts-vivid": "4.4.0.252.258",
            "linux-modules-4.4.0-252-generic": "4.4.0-252.286",
            "linux-headers-generic": "4.4.0.252.258",
            "linux-headers-lowlatency": "4.4.0.252.258",
            "linux-image-lowlatency": "4.4.0.252.258",
            "linux-image-extra-virtual-lts-xenial": "4.4.0.252.258",
            "linux-tools-virtual-lts-utopic": "4.4.0.252.258",
            "linux-tools-host": "4.4.0-252.286",
            "linux-headers-4.4.0-252": "4.4.0-252.286",
            "linux-headers-virtual-lts-wily": "4.4.0.252.258",
            "linux-signed-generic-lts-wily": "4.4.0.252.258",
            "linux-signed-generic-lts-xenial": "4.4.0.252.258",
            "linux-signed-generic-lts-utopic": "4.4.0.252.258",
            "linux-cloud-tools-generic-lts-utopic": "4.4.0.252.258",
            "linux-image-virtual-lts-wily": "4.4.0.252.258",
            "linux-hwe-virtual-trusty": "4.4.0.252.258",
            "linux-tools-lowlatency-lts-utopic": "4.4.0.252.258",
            "linux-signed-generic": "4.4.0.252.258",
            "linux-modules-4.4.0-252-lowlatency": "4.4.0-252.286",
            "linux-headers-4.4.0-252-generic": "4.4.0-252.286",
            "linux-virtual-lts-wily": "4.4.0.252.258",
            "linux-tools-lowlatency-lts-xenial": "4.4.0.252.258",
            "linux-tools-virtual-lts-xenial": "4.4.0.252.258",
            "linux-tools-4.4.0-252-generic": "4.4.0-252.286"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / linux-kvm

Package

Name
linux-kvm

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.4.0-1130.140

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "linux-headers-kvm": "4.4.0.1130.127",
            "linux-kvm-cloud-tools-4.4.0-1130": "4.4.0-1130.140",
            "linux-kvm": "4.4.0.1130.127",
            "linux-buildinfo-4.4.0-1130-kvm": "4.4.0-1130.140",
            "linux-kvm-headers-4.4.0-1130": "4.4.0-1130.140",
            "linux-tools-kvm": "4.4.0.1130.127",
            "linux-kvm-tools-4.4.0-1130": "4.4.0-1130.140",
            "linux-image-4.4.0-1130-kvm": "4.4.0-1130.140",
            "linux-headers-4.4.0-1130-kvm": "4.4.0-1130.140",
            "linux-tools-4.4.0-1130-kvm": "4.4.0-1130.140",
            "linux-cloud-tools-4.4.0-1130-kvm": "4.4.0-1130.140",
            "linux-image-kvm": "4.4.0.1130.127",
            "linux-modules-4.4.0-1130-kvm": "4.4.0-1130.140"
        }
    ]
}