USN-6702-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-6702-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6702-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6702-2
Related
Published
2024-03-20T22:30:12.163168Z
Modified
2024-03-20T22:30:12.163168Z
Summary
linux-aws, linux-aws-5.4, linux-gcp-5.4, linux-raspi, linux-raspi-5.4, linux-xilinx-zynqmp vulnerabilities
Details

It was discovered that the NVIDIA Tegra XUSB pad controller driver in the Linux kernel did not properly handle return values in certain error conditions. A local attacker could use this to cause a denial of service (system crash). (CVE-2023-23000)

It was discovered that the ARM Mali Display Processor driver implementation in the Linux kernel did not properly handle certain error conditions. A local attacker could possibly use this to cause a denial of service (system crash). (CVE-2023-23004)

Notselwyn discovered that the netfilter subsystem in the Linux kernel did not properly handle verdict parameters in certain cases, leading to a use- after-free vulnerability. A local attacker could use this to cause a denial of service (system crash) or possibly execute arbitrary code. (CVE-2024-1086)

It was discovered that a race condition existed in the SCSI Emulex LightPulse Fibre Channel driver in the Linux kernel when unregistering FCF and re-scanning an HBA FCF table, leading to a null pointer dereference vulnerability. A local attacker could use this to cause a denial of service (system crash). (CVE-2024-24855)

References

Affected packages

Ubuntu:Pro:18.04:LTS / linux-aws-5.4

Package

Name
linux-aws-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1121.131~18.04.1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "linux-aws-5.4-cloud-tools-5.4.0-1121": "5.4.0-1121.131~18.04.1",
            "linux-aws-5.4-headers-5.4.0-1121": "5.4.0-1121.131~18.04.1",
            "linux-tools-5.4.0-1121-aws": "5.4.0-1121.131~18.04.1",
            "linux-image-aws-edge": "5.4.0.1121.99",
            "linux-headers-aws": "5.4.0.1121.99",
            "linux-buildinfo-5.4.0-1121-aws": "5.4.0-1121.131~18.04.1",
            "linux-aws": "5.4.0.1121.99",
            "linux-image-aws": "5.4.0.1121.99",
            "linux-modules-5.4.0-1121-aws": "5.4.0-1121.131~18.04.1",
            "linux-headers-aws-edge": "5.4.0.1121.99",
            "linux-cloud-tools-5.4.0-1121-aws": "5.4.0-1121.131~18.04.1",
            "linux-modules-extra-aws-edge": "5.4.0.1121.99",
            "linux-image-5.4.0-1121-aws": "5.4.0-1121.131~18.04.1",
            "linux-headers-5.4.0-1121-aws": "5.4.0-1121.131~18.04.1",
            "linux-image-unsigned-5.4.0-1121-aws": "5.4.0-1121.131~18.04.1",
            "linux-modules-extra-aws": "5.4.0.1121.99",
            "linux-tools-aws-edge": "5.4.0.1121.99",
            "linux-aws-edge": "5.4.0.1121.99",
            "linux-modules-extra-5.4.0-1121-aws": "5.4.0-1121.131~18.04.1",
            "linux-aws-5.4-tools-5.4.0-1121": "5.4.0-1121.131~18.04.1",
            "linux-tools-aws": "5.4.0.1121.99"
        }
    ]
}

Ubuntu:Pro:18.04:LTS / linux-gcp-5.4

Package

Name
linux-gcp-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1125.134~18.04.1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "linux-gcp-5.4-headers-5.4.0-1125": "5.4.0-1125.134~18.04.1",
            "linux-tools-gcp": "5.4.0.1125.101",
            "linux-modules-5.4.0-1125-gcp": "5.4.0-1125.134~18.04.1",
            "linux-buildinfo-5.4.0-1125-gcp": "5.4.0-1125.134~18.04.1",
            "linux-headers-gcp-edge": "5.4.0.1125.101",
            "linux-gcp": "5.4.0.1125.101",
            "linux-tools-gcp-edge": "5.4.0.1125.101",
            "linux-gcp-5.4-tools-5.4.0-1125": "5.4.0-1125.134~18.04.1",
            "linux-headers-5.4.0-1125-gcp": "5.4.0-1125.134~18.04.1",
            "linux-image-gcp-edge": "5.4.0.1125.101",
            "linux-headers-gcp": "5.4.0.1125.101",
            "linux-image-gcp": "5.4.0.1125.101",
            "linux-modules-extra-gcp": "5.4.0.1125.101",
            "linux-gcp-edge": "5.4.0.1125.101",
            "linux-modules-extra-gcp-edge": "5.4.0.1125.101",
            "linux-tools-5.4.0-1125-gcp": "5.4.0-1125.134~18.04.1",
            "linux-image-unsigned-5.4.0-1125-gcp": "5.4.0-1125.134~18.04.1",
            "linux-image-5.4.0-1125-gcp": "5.4.0-1125.134~18.04.1",
            "linux-modules-extra-5.4.0-1125-gcp": "5.4.0-1125.134~18.04.1"
        }
    ]
}

Ubuntu:Pro:18.04:LTS / linux-raspi-5.4

Package

Name
linux-raspi-5.4

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1105.117~18.04.1

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "linux-image-raspi-hwe-18.04-edge": "5.4.0.1105.102",
            "linux-raspi-5.4-headers-5.4.0-1105": "5.4.0-1105.117~18.04.1",
            "linux-tools-raspi-hwe-18.04-edge": "5.4.0.1105.102",
            "linux-image-5.4.0-1105-raspi": "5.4.0-1105.117~18.04.1",
            "linux-raspi-hwe-18.04-edge": "5.4.0.1105.102",
            "linux-tools-5.4.0-1105-raspi": "5.4.0-1105.117~18.04.1",
            "linux-modules-5.4.0-1105-raspi": "5.4.0-1105.117~18.04.1",
            "linux-image-raspi-hwe-18.04": "5.4.0.1105.102",
            "linux-raspi-hwe-18.04": "5.4.0.1105.102",
            "linux-headers-raspi-hwe-18.04": "5.4.0.1105.102",
            "linux-buildinfo-5.4.0-1105-raspi": "5.4.0-1105.117~18.04.1",
            "linux-raspi-5.4-tools-5.4.0-1105": "5.4.0-1105.117~18.04.1",
            "linux-headers-5.4.0-1105-raspi": "5.4.0-1105.117~18.04.1",
            "linux-headers-raspi-hwe-18.04-edge": "5.4.0.1105.102",
            "linux-tools-raspi-hwe-18.04": "5.4.0.1105.102"
        }
    ]
}

Ubuntu:20.04:LTS / linux-aws

Package

Name
linux-aws

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1121.131

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-aws-cloud-tools-5.4.0-1121": "5.4.0-1121.131",
            "linux-tools-5.4.0-1121-aws": "5.4.0-1121.131",
            "linux-modules-extra-aws-lts-20.04": "5.4.0.1121.118",
            "linux-aws-headers-5.4.0-1121": "5.4.0-1121.131",
            "linux-buildinfo-5.4.0-1121-aws": "5.4.0-1121.131",
            "linux-aws-lts-20.04": "5.4.0.1121.118",
            "linux-tools-aws-lts-20.04": "5.4.0.1121.118",
            "linux-modules-5.4.0-1121-aws": "5.4.0-1121.131",
            "linux-headers-aws-lts-20.04": "5.4.0.1121.118",
            "linux-cloud-tools-5.4.0-1121-aws": "5.4.0-1121.131",
            "linux-aws-tools-5.4.0-1121": "5.4.0-1121.131",
            "linux-headers-5.4.0-1121-aws": "5.4.0-1121.131",
            "linux-image-5.4.0-1121-aws": "5.4.0-1121.131",
            "linux-image-unsigned-5.4.0-1121-aws": "5.4.0-1121.131",
            "linux-modules-extra-5.4.0-1121-aws": "5.4.0-1121.131",
            "linux-image-aws-lts-20.04": "5.4.0.1121.118"
        }
    ]
}

Ubuntu:20.04:LTS / linux-raspi

Package

Name
linux-raspi

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1105.117

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-image-raspi2-hwe-18.04-edge": "5.4.0.1105.135",
            "linux-tools-5.4.0-1105-raspi": "5.4.0-1105.117",
            "linux-image-raspi2": "5.4.0.1105.135",
            "linux-image-5.4.0-1105-raspi": "5.4.0-1105.117",
            "linux-raspi-hwe-18.04-edge": "5.4.0.1105.135",
            "linux-tools-raspi-hwe-18.04-edge": "5.4.0.1105.135",
            "linux-modules-5.4.0-1105-raspi": "5.4.0-1105.117",
            "linux-headers-raspi": "5.4.0.1105.135",
            "linux-raspi-headers-5.4.0-1105": "5.4.0-1105.117",
            "linux-headers-raspi-hwe-18.04": "5.4.0.1105.135",
            "linux-buildinfo-5.4.0-1105-raspi": "5.4.0-1105.117",
            "linux-headers-raspi-hwe-18.04-edge": "5.4.0.1105.135",
            "linux-raspi2-hwe-18.04-edge": "5.4.0.1105.135",
            "linux-image-raspi": "5.4.0.1105.135",
            "linux-headers-raspi2-hwe-18.04": "5.4.0.1105.135",
            "linux-image-raspi2-hwe-18.04": "5.4.0.1105.135",
            "linux-image-raspi-hwe-18.04-edge": "5.4.0.1105.135",
            "linux-tools-raspi2-hwe-18.04-edge": "5.4.0.1105.135",
            "linux-headers-raspi2-hwe-18.04-edge": "5.4.0.1105.135",
            "linux-tools-raspi": "5.4.0.1105.135",
            "linux-raspi-tools-5.4.0-1105": "5.4.0-1105.117",
            "linux-tools-raspi2-hwe-18.04": "5.4.0.1105.135",
            "linux-raspi2-hwe-18.04": "5.4.0.1105.135",
            "linux-raspi": "5.4.0.1105.135",
            "linux-image-raspi-hwe-18.04": "5.4.0.1105.135",
            "linux-headers-raspi2": "5.4.0.1105.135",
            "linux-tools-raspi2": "5.4.0.1105.135",
            "linux-raspi-hwe-18.04": "5.4.0.1105.135",
            "linux-raspi2": "5.4.0.1105.135",
            "linux-headers-5.4.0-1105-raspi": "5.4.0-1105.117",
            "linux-tools-raspi-hwe-18.04": "5.4.0.1105.135"
        }
    ]
}

Ubuntu:20.04:LTS / linux-xilinx-zynqmp

Package

Name
linux-xilinx-zynqmp

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.4.0-1040.44

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "linux-headers-xilinx-zynqmp": "5.4.0.1040.40",
            "linux-buildinfo-5.4.0-1040-xilinx-zynqmp": "5.4.0-1040.44",
            "linux-image-xilinx-zynqmp": "5.4.0.1040.40",
            "linux-headers-5.4.0-1040-xilinx-zynqmp": "5.4.0-1040.44",
            "linux-xilinx-zynqmp": "5.4.0.1040.40",
            "linux-modules-5.4.0-1040-xilinx-zynqmp": "5.4.0-1040.44",
            "linux-image-5.4.0-1040-xilinx-zynqmp": "5.4.0-1040.44",
            "linux-xilinx-zynqmp-headers-5.4.0-1040": "5.4.0-1040.44",
            "linux-tools-5.4.0-1040-xilinx-zynqmp": "5.4.0-1040.44",
            "linux-tools-xilinx-zynqmp": "5.4.0.1040.40",
            "linux-xilinx-zynqmp-tools-5.4.0-1040": "5.4.0-1040.44"
        }
    ]
}