USN-6721-2

See a problem?
Source
https://ubuntu.com/security/notices/USN-6721-2
Import Source
https://github.com/canonical/ubuntu-security-notices/blob/main/osv/USN-6721-2.json
JSON Data
https://api.osv.dev/v1/vulns/USN-6721-2
Published
2024-04-09T21:16:47.333558Z
Modified
2024-04-09T21:16:47.333558Z
Summary
xorg-server, xwayland regression
Details

USN-6721-1 fixed vulnerabilities in X.Org X Server. That fix was incomplete resulting in a regression. This update fixes the problem.

We apologize for the inconvenience.

Original advisory details:

It was discovered that X.Org X Server incorrectly handled certain data. An attacker could possibly use this issue to expose sensitive information. (CVE-2024-31080, CVE-2024-31081, CVE-2024-31082)

It was discovered that X.Org X Server incorrectly handled certain glyphs. An attacker could possibly use this issue to cause a crash or expose sensitive information. (CVE-2024-31083)

References

Affected packages

Ubuntu:Pro:18.04:LTS / xorg-server

Package

Name
xorg-server

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:1.19.6-1ubuntu4.15+esm8

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "xdmx-tools": "2:1.19.6-1ubuntu4.15+esm8",
            "xserver-xephyr": "2:1.19.6-1ubuntu4.15+esm8",
            "xvfb": "2:1.19.6-1ubuntu4.15+esm8",
            "xserver-xorg-legacy": "2:1.19.6-1ubuntu4.15+esm8",
            "xdmx": "2:1.19.6-1ubuntu4.15+esm8",
            "xmir": "2:1.19.6-1ubuntu4.15+esm8",
            "xserver-xorg-dev": "2:1.19.6-1ubuntu4.15+esm8",
            "xorg-server-source": "2:1.19.6-1ubuntu4.15+esm8",
            "xserver-xorg-core": "2:1.19.6-1ubuntu4.15+esm8",
            "xserver-common": "2:1.19.6-1ubuntu4.15+esm8",
            "xnest": "2:1.19.6-1ubuntu4.15+esm8",
            "xserver-xorg-xmir": "2:1.19.6-1ubuntu4.15+esm8",
            "xwayland": "2:1.19.6-1ubuntu4.15+esm8"
        }
    ]
}

Ubuntu:20.04:LTS / xorg-server

Package

Name
xorg-server

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:1.20.13-1ubuntu1~20.04.17

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "xdmx-tools": "2:1.20.13-1ubuntu1~20.04.17",
            "xvfb": "2:1.20.13-1ubuntu1~20.04.17",
            "xserver-xorg-legacy": "2:1.20.13-1ubuntu1~20.04.17",
            "xdmx": "2:1.20.13-1ubuntu1~20.04.17",
            "xserver-xorg-dev": "2:1.20.13-1ubuntu1~20.04.17",
            "xorg-server-source": "2:1.20.13-1ubuntu1~20.04.17",
            "xserver-xorg-core": "2:1.20.13-1ubuntu1~20.04.17",
            "xserver-common": "2:1.20.13-1ubuntu1~20.04.17",
            "xnest": "2:1.20.13-1ubuntu1~20.04.17",
            "xserver-xephyr": "2:1.20.13-1ubuntu1~20.04.17",
            "xwayland": "2:1.20.13-1ubuntu1~20.04.17"
        }
    ]
}

Ubuntu:22.04:LTS / xorg-server

Package

Name
xorg-server

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:21.1.4-2ubuntu1.7~22.04.10

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "xvfb": "2:21.1.4-2ubuntu1.7~22.04.10",
            "xserver-xorg-legacy": "2:21.1.4-2ubuntu1.7~22.04.10",
            "xserver-xorg-dev": "2:21.1.4-2ubuntu1.7~22.04.10",
            "xorg-server-source": "2:21.1.4-2ubuntu1.7~22.04.10",
            "xserver-xorg-core": "2:21.1.4-2ubuntu1.7~22.04.10",
            "xserver-common": "2:21.1.4-2ubuntu1.7~22.04.10",
            "xnest": "2:21.1.4-2ubuntu1.7~22.04.10",
            "xserver-xephyr": "2:21.1.4-2ubuntu1.7~22.04.10"
        }
    ]
}

Ubuntu:22.04:LTS / xwayland

Package

Name
xwayland

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:22.1.1-1ubuntu0.13

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "xwayland": "2:22.1.1-1ubuntu0.13"
        }
    ]
}

Ubuntu:23.10 / xorg-server

Package

Name
xorg-server

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:21.1.7-3ubuntu2.9

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "xvfb": "2:21.1.7-3ubuntu2.9",
            "xserver-xorg-legacy": "2:21.1.7-3ubuntu2.9",
            "xserver-xorg-dev": "2:21.1.7-3ubuntu2.9",
            "xorg-server-source": "2:21.1.7-3ubuntu2.9",
            "xserver-xorg-core": "2:21.1.7-3ubuntu2.9",
            "xserver-common": "2:21.1.7-3ubuntu2.9",
            "xnest": "2:21.1.7-3ubuntu2.9",
            "xserver-xephyr": "2:21.1.7-3ubuntu2.9"
        }
    ]
}

Ubuntu:23.10 / xwayland

Package

Name
xwayland

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:23.2.0-1ubuntu0.6

Ecosystem specific

{
    "availability": "No subscription needed",
    "binaries": [
        {
            "xwayland": "2:23.2.0-1ubuntu0.6"
        }
    ]
}

Ubuntu:Pro:14.04:LTS / xorg-server

Package

Name
xorg-server

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:1.15.1-0ubuntu2.11+esm12

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "xdmx-tools": "2:1.15.1-0ubuntu2.11+esm12",
            "xvfb": "2:1.15.1-0ubuntu2.11+esm12",
            "xdmx": "2:1.15.1-0ubuntu2.11+esm12",
            "xserver-xorg-dev": "2:1.15.1-0ubuntu2.11+esm12",
            "xorg-server-source": "2:1.15.1-0ubuntu2.11+esm12",
            "xserver-xorg-core": "2:1.15.1-0ubuntu2.11+esm12",
            "xserver-common": "2:1.15.1-0ubuntu2.11+esm12",
            "xnest": "2:1.15.1-0ubuntu2.11+esm12",
            "xserver-xephyr": "2:1.15.1-0ubuntu2.11+esm12",
            "xserver-xorg-xmir": "2:1.15.1-0ubuntu2.11+esm12"
        }
    ]
}

Ubuntu:Pro:16.04:LTS / xorg-server

Package

Name
xorg-server

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2:1.18.4-0ubuntu0.12+esm13

Ecosystem specific

{
    "availability": "Available with Ubuntu Pro: https://ubuntu.com/pro",
    "binaries": [
        {
            "xdmx-tools": "2:1.18.4-0ubuntu0.12+esm13",
            "xserver-xephyr": "2:1.18.4-0ubuntu0.12+esm13",
            "xvfb": "2:1.18.4-0ubuntu0.12+esm13",
            "xserver-xorg-legacy": "2:1.18.4-0ubuntu0.12+esm13",
            "xdmx": "2:1.18.4-0ubuntu0.12+esm13",
            "xmir": "2:1.18.4-0ubuntu0.12+esm13",
            "xserver-xorg-dev": "2:1.18.4-0ubuntu0.12+esm13",
            "xorg-server-source": "2:1.18.4-0ubuntu0.12+esm13",
            "xserver-xorg-core": "2:1.18.4-0ubuntu0.12+esm13",
            "xserver-common": "2:1.18.4-0ubuntu0.12+esm13",
            "xnest": "2:1.18.4-0ubuntu0.12+esm13",
            "xserver-xorg-xmir": "2:1.18.4-0ubuntu0.12+esm13",
            "xwayland": "2:1.18.4-0ubuntu0.12+esm13"
        }
    ]
}