ALSA-2024:3666

See a problem?
Source
https://errata.almalinux.org/8/ALSA-2024-3666.html
Import Source
https://github.com/AlmaLinux/osv-database/blob/master/advisories/almalinux8/ALSA-2024:3666.json
JSON Data
https://api.osv.dev/v1/vulns/ALSA-2024:3666
Related
  • CVE-2024-23672
  • CVE-2024-24549
Published
2024-06-06T00:00:00Z
Modified
2024-06-06T12:55:40Z
Summary
Important: tomcat security and bug fix update
Details

Apache Tomcat is a servlet container for the Java Servlet and JavaServer Pages (JSP) technologies.

Security Fix(es):

  • Apache Tomcat: HTTP/2 header handling DoS (CVE-2024-24549)
  • Apache Tomcat: WebSocket DoS with incomplete closing handshake (CVE-2024-23672)

Bug Fix(es):

  • Rebase tomcat to version 9.0.87 (JIRA:AlmaLinux-35813)
  • Amend tomcat package's changelog so that fixed CVEs are mentioned explicitly (JIRA:AlmaLinux-38548)

For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References

Affected packages

AlmaLinux:8 / tomcat

Package

Name
tomcat

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:9.0.87-1.el8_10.1.alma.1

AlmaLinux:8 / tomcat-admin-webapps

Package

Name
tomcat-admin-webapps

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:9.0.87-1.el8_10.1.alma.1

AlmaLinux:8 / tomcat-docs-webapp

Package

Name
tomcat-docs-webapp

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:9.0.87-1.el8_10.1.alma.1

AlmaLinux:8 / tomcat-el-3.0-api

Package

Name
tomcat-el-3.0-api

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:9.0.87-1.el8_10.1.alma.1

AlmaLinux:8 / tomcat-jsp-2.3-api

Package

Name
tomcat-jsp-2.3-api

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:9.0.87-1.el8_10.1.alma.1

AlmaLinux:8 / tomcat-lib

Package

Name
tomcat-lib

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:9.0.87-1.el8_10.1.alma.1

AlmaLinux:8 / tomcat-servlet-4.0-api

Package

Name
tomcat-servlet-4.0-api

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:9.0.87-1.el8_10.1.alma.1

AlmaLinux:8 / tomcat-webapps

Package

Name
tomcat-webapps

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1:9.0.87-1.el8_10.1.alma.1