BIT-cilium-operator-2023-39347

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/cilium-operator/BIT-cilium-operator-2023-39347.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-cilium-operator-2023-39347
Aliases
Published
2024-05-15T12:06:55.378Z
Modified
2024-07-01T12:27:13.229579Z
Summary
[none]
Details

Cilium is a networking, observability, and security solution with an eBPF-based dataplane. An attacker with the ability to update pod labels can cause Cilium to apply incorrect network policies. This issue arises due to the fact that on pod update, Cilium incorrectly uses user-provided pod labels to select the policies which apply to the workload in question. This can affect Cilium network policies that use the namespace, service account or cluster constructs to restrict traffic, Cilium clusterwide network policies that use Cilium namespace labels to select the Pod and Kubernetes network policies. Non-existent construct names can be provided, which bypass all network policies applicable to the construct. For example, providing a pod with a non-existent namespace as the value of the io.kubernetes.pod.namespace label results in none of the namespaced CiliumNetworkPolicies applying to the pod in question. This attack requires the attacker to have Kubernetes API Server access, as described in the Cilium Threat Model. This issue has been resolved in: Cilium versions 1.14.2, 1.13.7, and 1.12.14. Users are advised to upgrade. As a workaround an admission webhook can be used to prevent pod label updates to the k8s:io.kubernetes.pod.namespace and io.cilium.k8s.policy.* keys.

References

Affected packages

Bitnami / cilium-operator

Package

Name
cilium-operator
Purl
pkg:bitnami/cilium-operator

Severity

  • 9.0 (Critical) CVSS_V3 - CVSS:3.1/AV:A/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.12.14
Introduced
1.13.0
Fixed
1.13.7
Introduced
1.14.0
Fixed
1.14.2