BIT-opencart-2024-21518

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/opencart/BIT-opencart-2024-21518.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-opencart-2024-21518
Aliases
Published
2024-06-25T11:57:47.671Z
Modified
2024-06-25T12:44:28.204534Z
Summary
[none]
Details

This affects versions of the package opencart/opencart from 4.0.0-0. A Zip Slip issue was identified via the marketplace installer due to improper sanitization of the target path, allowing files within a malicious archive to traverse the filesystem and be extracted to arbitrary locations. An attacker can create arbitrary files in the web root of the application and overwrite other existing files by exploiting this vulnerability.

References

Affected packages

Bitnami / opencart

Package

Name
opencart
Purl
pkg:bitnami/opencart

Severity

  • 7.2 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
4.0.0-0