GHSA-m7r8-2r98-vppj

Suggest an improvement
Source
https://github.com/advisories/GHSA-m7r8-2r98-vppj
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2024/06/GHSA-m7r8-2r98-vppj/GHSA-m7r8-2r98-vppj.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-m7r8-2r98-vppj
Aliases
Published
2024-06-22T06:30:37Z
Modified
2024-07-05T17:40:18Z
Severity
  • 7.2 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
  • 8.4 (High) CVSS_V4 - CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N CVSS Calculator
Summary
Zip slip in opencart
Details

This affects versions of the package opencart/opencart from 4.0.0.0. A Zip Slip issue was identified via the marketplace installer due to improper sanitization of the target path, allowing files within a malicious archive to traverse the filesystem and be extracted to arbitrary locations. An attacker can create arbitrary files in the web root of the application and overwrite other existing files by exploiting this vulnerability.

References

Affected packages

Packagist / opencart/opencart

Package

Name
opencart/opencart
Purl
pkg:composer/opencart/opencart

Affected ranges

Type
ECOSYSTEM
Events
Introduced
4.0.0.0