BIT-solr-2023-50386

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/solr/BIT-solr-2023-50386.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-solr-2023-50386
Aliases
Published
2024-03-06T11:05:01.473Z
Modified
2024-03-06T11:25:28.861Z
Summary
[none]
Details

Improper Control of Dynamically-Managed Code Resources, Unrestricted Upload of File with Dangerous Type, Inclusion of Functionality from Untrusted Control Sphere vulnerability in Apache Solr.This issue affects Apache Solr: from 6.0.0 through 8.11.2, from 9.0.0 before 9.4.1.In the affected versions, Solr ConfigSets accepted Java jar and class files to be uploaded through the ConfigSets API.When backing up Solr Collections, these configSet files would be saved to disk when using the LocalFileSystemRepository (the default for backups).If the backup was saved to a directory that Solr uses in its ClassPath/ClassLoaders, then the jar and class files would be available to use with any ConfigSet, trusted or untrusted.When Solr is run in a secure way (Authorization enabled), as is strongly suggested, this vulnerability is limited to extending the Backup permissions with the ability to add libraries.Users are recommended to upgrade to version 8.11.3 or 9.4.1, which fix the issue.In these versions, the following protections have been added: * Users are no longer able to upload files to a configSet that could be executed via a Java ClassLoader. * The Backup API restricts saving backups to directories that are used in the ClassLoader.

References

Affected packages

Bitnami / solr

Package

Name
solr
Purl
pkg:bitnami/solr

Severity

  • 8.8 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
6.0.0
Fixed
8.11.3
Introduced
9.0.0
Fixed
9.4.1