CVE-2023-2283

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2023-2283
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-2283.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2023-2283
Related
Published
2023-05-26T18:15:13Z
Modified
2024-06-06T14:17:27.747590Z
Severity
  • CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
Summary
[none]
Details

A vulnerability was found in libssh, where the authentication check of the connecting client can be bypassed in thepki_verify_data_signature function in memory allocation problems. This issue may happen if there is insufficient memory or the memory usage is limited. The problem is caused by the return value rc, which is initialized to SSHERROR and later rewritten to save the return value of the function call pki_key_check_hash_compatible. The value of the variable is not changed between this point and the cryptographic verification. Therefore any error between them calls goto error returning SSHOK.

References

Affected packages

Git / gitlab.com/libssh/libssh-mirror

Affected ranges

Type
GIT
Repo
https://gitlab.com/libssh/libssh-mirror
Events

Affected versions

libssh-0.*

libssh-0.10.0
libssh-0.10.2
libssh-0.10.3
libssh-0.10.4
libssh-0.9.1
libssh-0.9.2
libssh-0.9.3
libssh-0.9.4
libssh-0.9.5
libssh-0.9.6