CVE-2023-29020

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2023-29020
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-29020.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2023-29020
Aliases
Published
2023-04-21T23:15:20Z
Modified
2024-05-30T04:03:28.413028Z
Severity
  • 6.5 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N CVSS Calculator
Summary
[none]
Details

@fastify/passport is a port of passport authentication library for the Fastify ecosystem. The CSRF (Cross-Site Request Forger) protection enforced by the @fastify/csrf-protection library, when combined with @fastify/passport in affected versions, can be bypassed by network and same-site attackers. fastify/csrf-protection implements the synchronizer token pattern (using plugins @fastify/session and @fastify/secure-session) by storing a random value used for CSRF token generation in the _csrf attribute of a user's session. The @fastify/passport library does not clear the session object upon authentication, preserving the _csrf attribute between pre-login and authenticated sessions. Consequently, CSRF tokens generated before authentication are still valid. Network and same-site attackers can thus obtain a CSRF token for their pre-session, fixate that pre-session in the victim's browser via cookie tossing, and then perform a CSRF attack after the victim authenticates. As a solution, newer versions of @fastify/passport include the configuration options: clearSessionOnLogin (default: true) and clearSessionIgnoreFields (default: ['passport', 'session']) to clear all the session attributes by default, preserving those explicitly defined in clearSessionIgnoreFields.

References

Affected packages

Git / github.com/fastify/fastify-passport

Affected ranges

Type
GIT
Repo
https://github.com/fastify/fastify-passport
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed

Affected versions

v0.*

v0.1.0
v0.2.0
v0.3.0
v0.4.1
v0.5.0

v1.*

v1.0.0
v1.0.1

v2.*

v2.0.0
v2.0.1
v2.1.0
v2.2.0