CVE-2023-47248

Source
https://nvd.nist.gov/vuln/detail/CVE-2023-47248
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-47248.json
Aliases
Published
2023-11-09T09:15:08Z
Modified
2023-11-29T10:20:17.522078Z
Details

Deserialization of untrusted data in IPC and Parquet readers in PyArrow versions 0.14.0 to 14.0.0 allows arbitrary code execution. An application is vulnerable if it reads Arrow IPC, Feather or Parquet data from untrusted sources (for example user-supplied input files).

This vulnerability only affects PyArrow, not other Apache Arrow implementations or bindings.

It is recommended that users of PyArrow upgrade to 14.0.1. Similarly, it is recommended that downstream libraries upgrade their dependency requirements to PyArrow 14.0.1 or later. PyPI packages are already available, and we hope that conda-forge packages will be available soon.

If it is not possible to upgrade, we provide a separate package pyarrow-hotfix that disables the vulnerability on older PyArrow versions. See https://pypi.org/project/pyarrow-hotfix/ for instructions.

References

Affected packages

Git / github.com/apache/arrow

Affected ranges

Type
GIT
Repo
https://github.com/apache/arrow
Events

Affected versions

apache-arrow-0.*

apache-arrow-0.14.0
apache-arrow-0.15.0
apache-arrow-0.16.0
apache-arrow-0.17.0

apache-arrow-1.*

apache-arrow-1.0.0

apache-arrow-10.*

apache-arrow-10.0.0.dev

apache-arrow-11.*

apache-arrow-11.0.0.dev

apache-arrow-12.*

apache-arrow-12.0.0.dev

apache-arrow-13.*

apache-arrow-13.0.0.dev

apache-arrow-14.*

apache-arrow-14.0.0
apache-arrow-14.0.0.dev

apache-arrow-2.*

apache-arrow-2.0.0

apache-arrow-3.*

apache-arrow-3.0.0

apache-arrow-5.*

apache-arrow-5.0.0.dev

apache-arrow-6.*

apache-arrow-6.0.0.dev

apache-arrow-7.*

apache-arrow-7.0.0.dev

apache-arrow-8.*

apache-arrow-8.0.0.dev

apache-arrow-9.*

apache-arrow-9.0.0.dev

go/v14.*

go/v14.0.0