GHSA-5wvp-7f3h-6wmm

Source
https://github.com/advisories/GHSA-5wvp-7f3h-6wmm
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/11/GHSA-5wvp-7f3h-6wmm/GHSA-5wvp-7f3h-6wmm.json
Aliases
Published
2023-11-09T09:30:26Z
Modified
2024-02-17T05:30:37.400475Z
Details

Deserialization of untrusted data in IPC and Parquet readers in PyArrow versions 0.14.0 to 14.0.0 allows arbitrary code execution. An application is vulnerable if it reads Arrow IPC, Feather or Parquet data from untrusted sources (for example user-supplied input files).

This vulnerability only affects PyArrow, not other Apache Arrow implementations or bindings.

It is recommended that users of PyArrow upgrade to 14.0.1. Similarly, it is recommended that downstream libraries upgrade their dependency requirements to PyArrow 14.0.1 or later. PyPI packages are already available, and we hope that conda-forge packages will be available soon.

If it is not possible to upgrade, maintainers provide a separate package pyarrow-hotfix that disables the vulnerability on older PyArrow versions. See https://pypi.org/project/pyarrow-hotfix/ for instructions.

References

Affected packages

PyPI / pyarrow

Package

Name
pyarrow

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0.14.0
Fixed
14.0.1

Affected versions

0.*

0.14.0
0.14.1
0.15.0
0.15.1
0.16.0
0.17.0
0.17.1

1.*

1.0.0
1.0.1

2.*

2.0.0

3.*

3.0.0

4.*

4.0.0
4.0.1

5.*

5.0.0

6.*

6.0.0
6.0.1

7.*

7.0.0

8.*

8.0.0

9.*

9.0.0

10.*

10.0.0
10.0.1

11.*

11.0.0

12.*

12.0.0
12.0.1

13.*

13.0.0

14.*

14.0.0