An issue has been discovered in GitLab CE/EE affecting all versions prior to 16.10.7, starting from 16.11 prior to 16.11.4, and starting from 17.0 prior to 17.0.2. A vulnerability in GitLab's CI/CD pipeline editor could allow for denial of service attacks through maliciously crafted configuration files.
{
"cna_assigner": "GitLab",
"cwe_ids": [
"CWE-1333"
],
"osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2024/1xxx/CVE-2024-1736.json"
}{
"extracted_events": [
{
"range": [
{
"introduced": "15.8"
},
{
"fixed": "16.10.7"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"range": [
{
"introduced": "16.11"
},
{
"fixed": "16.11.4"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
},
{
"range": [
{
"introduced": "17.0"
},
{
"fixed": "17.0.2"
}
],
"source": "AFFECTED_FIELD",
"strategy": "StandardRange"
}
]
}