CVE-2024-26141

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2024-26141
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-26141.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2024-26141
Aliases
Related
Published
2024-02-29T00:15:51Z
Modified
2024-06-10T20:20:23.792831Z
Summary
[none]
Details

Rack is a modular Ruby web server interface. Carefully crafted Range headers can cause a server to respond with an unexpectedly large response. Responding with such large responses could lead to a denial of service issue. Vulnerable applications will use the Rack::File middleware or the Rack::Utils.byte_ranges methods (this includes Rails applications). The vulnerability is fixed in 3.0.9.1 and 2.2.8.1.

References

Affected packages

Git / github.com/rack/rack

Affected ranges

Type
GIT
Repo
https://github.com/rack/rack
Events
Introduced
0 Unknown introduced commit / All previous commits are affected
Fixed
Fixed

Affected versions

0.*

0.1
0.2
0.3

1.*

1.0
1.1
1.2
1.2.1
1.3.0
1.3.0.beta
1.3.0.beta2
1.4.0
1.4.1
1.5.0
1.5.1
1.5.2
1.6.0
1.6.0.beta
1.6.0.beta2

2.*

2.0.0
2.0.0.alpha
2.0.0.rc1
2.0.1
2.1.0
2.2.0
2.2.3
2.2.3.1
2.2.4

3.*

3.0.0
3.0.0.beta1
3.0.0.rc1

v2.*

v2.2.1
v2.2.2
v2.2.5
v2.2.6
v2.2.6.1
v2.2.6.2
v2.2.6.3
v2.2.6.4
v2.2.7
v2.2.8

v3.*

v3.0.1
v3.0.2
v3.0.3
v3.0.4
v3.0.4.1
v3.0.4.2
v3.0.5
v3.0.6
v3.0.6.1
v3.0.7
v3.0.8
v3.0.9