CVE-2024-36114

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2024-36114
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2024-36114.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2024-36114
Aliases
Published
2024-05-29T21:15:49Z
Modified
2024-06-19T07:44:27.053053Z
Summary
[none]
Details

Aircompressor is a library with ports of the Snappy, LZO, LZ4, and Zstandard compression algorithms to Java. All decompressor implementations of Aircompressor (LZ4, LZO, Snappy, Zstandard) can crash the JVM for certain input, and in some cases also leak the content of other memory of the Java process (which could contain sensitive information). When decompressing certain data, the decompressors try to access memory outside the bounds of the given byte arrays or byte buffers. Because Aircompressor uses the JDK class sun.misc.Unsafe to speed up memory access, no additional bounds checks are performed and this has similar security consequences as out-of-bounds access in C or C++, namely it can lead to non-deterministic behavior or crash the JVM. Users should update to Aircompressor 0.27 or newer where these issues have been fixed. When decompressing data from untrusted users, this can be exploited for a denial-of-service attack by crashing the JVM, or to leak other sensitive information from the Java process. There are no known workarounds for this issue.

References

Affected packages

Git / github.com/airlift/aircompressor

Affected ranges

Type
GIT
Repo
https://github.com/airlift/aircompressor
Events

Affected versions

0.*

0.1
0.10
0.11
0.12
0.13
0.14
0.15
0.16
0.17
0.18
0.19
0.2
0.20
0.21
0.22
0.23
0.24
0.25
0.26
0.3
0.4
0.5
0.6
0.7
0.8
0.9