GHSA-973x-65j7-xcf4

Suggest an improvement
Source
https://github.com/advisories/GHSA-973x-65j7-xcf4
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2024/06/GHSA-973x-65j7-xcf4/GHSA-973x-65j7-xcf4.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-973x-65j7-xcf4
Aliases
Related
Published
2024-06-02T22:30:02Z
Modified
2024-07-15T22:12:28.049997Z
Severity
  • 8.6 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:H CVSS Calculator
Summary
Decompressors can crash the JVM and leak memory content in Aircompressor
Details

Summary

All decompressor implementations of Aircompressor (LZ4, LZO, Snappy, Zstandard) can crash the JVM for certain input, and in some cases also leak the content of other memory of the Java process (which could contain sensitive information).

Details

When decompressing certain data, the decompressors try to access memory outside the bounds of the given byte arrays or byte buffers. Because Aircompressor uses the JDK class sun.misc.Unsafe to speed up memory access, no additional bounds checks are performed and this has similar security consequences as out-of-bounds access in C or C++, namely it can lead to non-deterministic behavior or crash the JVM.

Users should update to Aircompressor 0.27 or newer where these issues have been fixed.

Impact

When decompressing data from untrusted users, this can be exploited for a denial-of-service attack by crashing the JVM, or to leak other sensitive information from the Java process.

References

Affected packages

Maven / io.airlift:aircompressor

Package

Name
io.airlift:aircompressor
View open source insights on deps.dev
Purl
pkg:maven/io.airlift/aircompressor

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.27

Affected versions

0.*

0.3
0.4
0.5
0.6
0.7
0.8
0.9
0.10
0.11
0.12
0.13
0.14
0.15
0.16
0.17
0.18
0.19
0.20
0.21
0.22
0.23
0.24
0.25
0.26