DLA-3194-1

Source
https://storage.googleapis.com/debian-osv/dla-osv/DLA-3194-1.json
Aliases
Published
2022-11-17T00:00:00Z
Modified
2022-11-18T15:18:34.839878Z
Details

Multiple security vulnerabilities have been found in Asterisk, an Open Source Private Branch Exchange. Buffer overflows and other programming errors could be exploited for information disclosure or the execution of arbitrary code.

Special care should be taken when upgrading to this new upstream release. Some configuration files and options have changed in order to remedy certain security vulnerabilities. Most notably the pjsip TLS listener only accepts TLSv1.3 connections in the default configuration now. This can be reverted by adding method=tlsv1_2 to the transport in pjsip.conf. See also https://issues.asterisk.org/jira/browse/ASTERISK-29017.

For Debian 10 buster, these problems have been fixed in version 1:16.28.0~dfsg-0+deb10u1.

We recommend that you upgrade your asterisk packages.

For the detailed security status of asterisk please refer to its security tracker page at: https://security-tracker.debian.org/tracker/asterisk

Further information about Debian LTS security advisories, how to apply these updates to your system and frequently asked questions can be found at: https://wiki.debian.org/LTS

References

Affected packages

Debian:10 / asterisk

asterisk

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0
Fixed
1:16.28.0~dfsg-0+deb10u1

Affected versions

1:16.*

1:16.10.0~dfsg-1
1:16.12.0~dfsg-1
1:16.15.0~dfsg-1
1:16.15.1~dfsg-1
1:16.16.1~dfsg+~2.10-1
1:16.16.1~dfsg+~2.10-2
1:16.16.1~dfsg-1
1:16.16.1~dfsg-1~bpo10+1
1:16.16.1~dfsg-2
1:16.16.1~dfsg-3
1:16.16.1~dfsg-4
1:16.2.1~dfsg-1
1:16.2.1~dfsg-1+deb10u1
1:16.2.1~dfsg-1+deb10u2
1:16.2.1~dfsg-2
1:16.23.0~dfsg+~2.10-1
1:16.23.0~dfsg+~cs6.10.20220309-1
1:16.23.0~dfsg+~cs6.10.20220309-2
1:16.23.0~dfsg+~cs6.10.40431411-1