GHSA-6m4h-hfpp-x8cx

Suggest an improvement
Source
https://github.com/advisories/GHSA-6m4h-hfpp-x8cx
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/12/GHSA-6m4h-hfpp-x8cx/GHSA-6m4h-hfpp-x8cx.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-6m4h-hfpp-x8cx
Aliases
Published
2022-12-22T00:30:36Z
Modified
2024-05-20T21:42:18Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
docconv OS Command Injection vulnerability
Details

A vulnerability was found in docconv prior to version 1.2.1. It has been declared as critical. This vulnerability affects the function ConvertPDFImages of the file pdf_ocr.go. The manipulation of the argument path leads to os command injection. The attack can be initiated remotely. Upgrading to version 1.2.1 can address this issue. The name of the patch is b19021ade3d0b71c89d35cb00eb9e589a121faa5. It is recommended to upgrade the affected component. VDB-216502 is the identifier assigned to this vulnerability.

References

Affected packages

Go / github.com/sajari/docconv

Package

Name
github.com/sajari/docconv
View open source insights on deps.dev
Purl
pkg:golang/github.com/sajari/docconv

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.2.1

Go / code.sajari.com/docconv

Package

Name
code.sajari.com/docconv
View open source insights on deps.dev
Purl
pkg:golang/code.sajari.com/docconv

Affected ranges

Type
SEMVER
Events
Introduced
1.1.0
Fixed
1.3.5