GO-2022-1184

See a problem?
Source
https://pkg.go.dev/vuln/GO-2022-1184
Import Source
https://vuln.go.dev/ID/GO-2022-1184.json
JSON Data
https://api.osv.dev/v1/vulns/GO-2022-1184
Aliases
Published
2022-12-27T18:18:39Z
Modified
2024-05-20T16:03:47Z
Summary
OS command injection vulnerability in code.sajari.com/docconv
Details

The manipulation of the argument path to docconv.{ConvertPDF,PDFHasImage} leads to os command injection.

References

Affected packages

Go / code.sajari.com/docconv

Package

Name
code.sajari.com/docconv
View open source insights on deps.dev
Purl
pkg:golang/code.sajari.com/docconv

Affected ranges

Type
SEMVER
Events
Introduced
1.1.0
Fixed
1.3.5

Ecosystem specific

{
    "imports": [
        {
            "path": "code.sajari.com/docconv",
            "symbols": [
                "Convert",
                "ConvertPDF",
                "ConvertPages",
                "ConvertPath",
                "ConvertPathReadability",
                "PDFHasImage"
            ]
        }
    ]
}