GHSA-9pc2-x9qf-7j2q

Suggest an improvement
Source
https://github.com/advisories/GHSA-9pc2-x9qf-7j2q
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/04/GHSA-9pc2-x9qf-7j2q/GHSA-9pc2-x9qf-7j2q.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-9pc2-x9qf-7j2q
Aliases
Published
2023-04-12T20:35:03Z
Modified
2023-11-08T04:12:17.820009Z
Severity
  • 9.9 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H CVSS Calculator
Summary
org.xwiki.platform:xwiki-platform-legacy-notification-activitymacro Eval Injection vulnerability
Details

Impact

Any user with view rights on commonly accessible documents including the legacy notification activity macro can execute arbitrary Groovy, Python or Velocity code in XWiki leading to full access to the XWiki installation. The root cause is improper escaping of the macro parameters of the legacy notification activity macro. This macro is installed by default in XWiki.

A proof of concept exploit is

{{activity wikis="~" /~}~} {{async async=~"true~" cached=~"false~" context=~"doc.reference~"~}~}{{groovy~}~}println(~"Hello from Groovy!~"){{/groovy~}~}"/}}

If the output of this macro is

The [notifications] macro is a standalone macro and it cannot be used inline. Click on this message for details.
Hello from Groovy!"    displayMinorEvents="false" displayRSSLink="false" /}}

or similar, the XWiki installation is vulnerable. The vulnerability can be exploited via every wiki page that is editable including the user's profile, but also with just view rights using the HTMLConverter that is part of the CKEditor integration which is bundled with XWiki.

Patches

The vulnerability has been patched in XWiki 13.10.11, 14.4.7 and 14.10.

Workarounds

The issue can be fixed by replacing the code of the legacy notification activity macro by the patched version. Alternatively, if the macro isn't used, the document XWiki.Notifications.Code.Legacy.ActivityMacro can also be completely deleted.

References

  • https://github.com/xwiki/xwiki-platform/commit/94392490884635c028199275db059a4f471e57bc
  • https://jira.xwiki.org/browse/XWIKI-20258

For more information

If you have any questions or comments about this advisory: * Open an issue in Jira XWiki.org * Email us at Security Mailing List

References

Affected packages

Maven / org.xwiki.platform:xwiki-platform-legacy-notification-activitymacro

Package

Name
org.xwiki.platform:xwiki-platform-legacy-notification-activitymacro
View open source insights on deps.dev
Purl
pkg:maven/org.xwiki.platform/xwiki-platform-legacy-notification-activitymacro

Affected ranges

Type
ECOSYSTEM
Events
Introduced
10.9
Fixed
13.10.11

Maven / org.xwiki.platform:xwiki-platform-legacy-notification-activitymacro

Package

Name
org.xwiki.platform:xwiki-platform-legacy-notification-activitymacro
View open source insights on deps.dev
Purl
pkg:maven/org.xwiki.platform/xwiki-platform-legacy-notification-activitymacro

Affected ranges

Type
ECOSYSTEM
Events
Introduced
14.0-rc-1
Fixed
14.4.7

Maven / org.xwiki.platform:xwiki-platform-legacy-notification-activitymacro

Package

Name
org.xwiki.platform:xwiki-platform-legacy-notification-activitymacro
View open source insights on deps.dev
Purl
pkg:maven/org.xwiki.platform/xwiki-platform-legacy-notification-activitymacro

Affected ranges

Type
ECOSYSTEM
Events
Introduced
14.5
Fixed
14.10