GHSA-f799-hfg3-48jp

Suggest an improvement
Source
https://github.com/advisories/GHSA-f799-hfg3-48jp
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-f799-hfg3-48jp/GHSA-f799-hfg3-48jp.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-f799-hfg3-48jp
Aliases
Published
2022-05-24T17:22:18Z
Modified
2023-11-08T04:02:56.478719Z
Severity
  • 5.4 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Stored XSS vulnerability in Jenkins Sonargraph Integration Plugin
Details

Sonargraph Integration Plugin 3.0.0 and earlier does not escape the file path for the Log file field form validation.

This results in a stored cross-site scripting (XSS) vulnerability that can be exploited by users with Job/Configure permission.

Sonargraph Integration Plugin 3.0.1 escapes the affected part of the error message.

References

Affected packages

Maven / org.jenkins-ci.plugins:sonargraph-integration

Package

Name
org.jenkins-ci.plugins:sonargraph-integration
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins/sonargraph-integration

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.0.1

Affected versions

1.*

1.0.2
1.0.3
1.0.4
1.0.5
1.1.3
1.1.4

2.*

2.0.0
2.0.1
2.0.2
2.1.0
2.1.1
2.1.2
2.2.0
2.2.1
2.2.2

3.*

3.0.0

Database specific

{
    "last_known_affected_version_range": "<= 3.0.0"
}