GHSA-mffc-9gx5-99g3

Suggest an improvement
Source
https://github.com/advisories/GHSA-mffc-9gx5-99g3
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-mffc-9gx5-99g3/GHSA-mffc-9gx5-99g3.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-mffc-9gx5-99g3
Aliases
Published
2022-05-14T01:46:42Z
Modified
2024-02-23T21:13:18.674606Z
Severity
  • 8.1 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
python-kerberos vulnerable to KDC spoofing attacks
Details

The checkPassword function in python-kerberos does not authenticate the KDC it attempts to communicate with, which allows remote attackers to cause a denial of service (bad response), or have other unspecified impact by performing a man-in-the-middle attack.

References

Affected packages

PyPI / kerberos

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
1.2.5

Affected versions

1.*

1.1.1
1.1.2
1.2.0
1.2.2
1.2.3
1.2.4
1.2.5