GHSA-qh8m-6g4p-33h3

Suggest an improvement
Source
https://github.com/advisories/GHSA-qh8m-6g4p-33h3
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-qh8m-6g4p-33h3/GHSA-qh8m-6g4p-33h3.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-qh8m-6g4p-33h3
Aliases
Published
2022-05-13T01:33:33Z
Modified
2024-04-24T00:11:48.754995Z
Severity
  • 8.1 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
Moodle Improper Authentication
Details

A flaw was found in Moodle 3.4 to 3.4.1, and 3.3 to 3.3.4. If a user account using OAuth2 authentication method was once confirmed but later suspended, the user could still login to the site.

References

Affected packages

Packagist / moodle/moodle

Package

Name
moodle/moodle
Purl
pkg:composer/moodle/moodle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
3.3
Fixed
3.3.5

Affected versions

v3.*

v3.3.0-beta
v3.3.0-rc1
v3.3.0-rc2
v3.3.0-rc3
v3.3.0
v3.3.1
v3.3.2
v3.3.3
v3.3.4

Packagist / moodle/moodle

Package

Name
moodle/moodle
Purl
pkg:composer/moodle/moodle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
3.4
Fixed
3.4.2

Affected versions

v3.*

v3.4.0-beta
v3.4.0-rc1
v3.4.0-rc2
v3.4.0-rc3
v3.4.0
v3.4.1