GHSA-rqm8-q8j9-662f

Source
https://github.com/advisories/GHSA-rqm8-q8j9-662f
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/03/GHSA-rqm8-q8j9-662f/GHSA-rqm8-q8j9-662f.json
Aliases
Published
2023-03-14T15:30:17Z
Modified
2023-11-08T04:11:15.989995Z
Details

Summary

A vulnerability was identified in Nomad and Nomad Enterprise (“Nomad”) such that a user with the submit-job ACL capability can submit a job that can escalate to management-level privileges. This vulnerability, CVE-2023-1299, was introduced in Nomad 1.5.0 and fixed in Nomad 1.5.1.

Background

Nomad 1.4.0 introduced the concept of workload identity so that tasks can access variables without needing to access them through Nomad HTTP API with an ACL token.

In 1.5.0, the identity block was introduced, which exposes the workload identity token to the workload so it can access Nomad HTTP API via a unix domain socket without configuring mTLS.

Details

During internal testing, we discovered it was possible to abuse the workload identity to elevate to management-level privilege if the workload identity did not have any attached ACL policies.

Remediation

Customers should evaluate the risk associated with this issue and consider upgrading to Nomad 1.5.1 or newer. See Nomad’s Upgrading for general guidance on this process.

References

Affected packages

Go / github.com/hashicorp/nomad

Affected ranges

Type
SEMVER
Events
Introduced
1.5.0
Fixed
1.5.1

Affected versions

1.*

1.5.0