RLSA-2023:6539

Import Source
https://storage.googleapis.com/resf-osv-data/RLSA-2023:6539.json
Related
Published
2024-05-10T14:32:42.380544Z
Modified
2024-05-10T14:34:23.651080Z
Summary
Moderate: perl-CPAN security update
Details

The CPAN module is a tool to query, download and build perl modules from CPAN sites.

Security Fix(es):

  • perl: CPAN.pm does not verify TLS certificates when downloading distributions over HTTPS (CVE-2023-31484)

For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

Additional Changes:

For detailed information on changes in this release, see the Rocky Linux 9.3 Release Notes linked from the References section.

References

Affected packages

Rocky Linux:9 / perl-CPAN

Package

Name
perl-CPAN

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0The exact introduced commit is unknown
Fixed
0:2.29-3.el9