BIT-symfony-2022-24895

See a problem?
Import Source
https://github.com/bitnami/vulndb/tree/main/data/symfony/BIT-symfony-2022-24895.json
JSON Data
https://api.osv.dev/v1/vulns/BIT-symfony-2022-24895
Aliases
Published
2024-03-06T11:07:02.565Z
Modified
2024-03-06T11:25:28.861Z
Summary
[none]
Details

Symfony is a PHP framework for web and console applications and a set of reusable PHP components. When authenticating users Symfony by default regenerates the session ID upon login, but preserves the rest of session attributes. Because this does not clear CSRF tokens upon login, this might enables same-site attackers to bypass the CSRF protection mechanism by performing an attack similar to a session-fixation. This issue has been fixed in the 4.4 branch.

References

Affected packages

Bitnami / symfony

Package

Name
symfony
Purl
pkg:bitnami/symfony

Severity

  • 8.8 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H CVSS Calculator

Affected ranges

Type
SEMVER
Events
Introduced
2.0.0
Fixed
4.4.50
Introduced
5.0.0
Fixed
5.4.20
Introduced
6.0.0
Fixed
6.0.20
Introduced
6.1.0
Fixed
6.1.12
Introduced
6.2.0
Fixed
6.2.6