CVE-2022-31626

Source
https://cve.org/CVERecord?id=CVE-2022-31626
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-31626.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2022-31626
Aliases
Downstream
ALPINE (1)
ALSA (2)
BELL (1)
CLEANSTART (1)
CLSA (5)
DEBIAN (1)
ECHO (1)
MGASA (1)
OESA (1)
openSUSE (1)
RHSA (5)
RLSA (3)
SUSE (10)
UBUNTU (1)
Related
Published
2022-06-16T05:45:16Z
Modified
2026-10-28T02:31:05Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
mysqlnd/pdo password buffer overflow
Details

In PHP versions 7.4.x below 7.4.30, 8.0.x below 8.0.20, and 8.1.x below 8.1.7, when pdo_mysql extension with mysqlnd driver, if the third party is allowed to supply host to connect to and the password for the connection, password of excessive length can trigger a buffer overflow in PHP, which can lead to a remote code execution vulnerability.

Database specific
{
    "cna_assigner": "php",
    "cwe_ids": [
        "CWE-120"
    ],
    "osv_generated_from": "https://github.com/CVEProject/cvelistV5/tree/main/cves/2022/31xxx/CVE-2022-31626.json",
    "unresolved_ranges": [
        {
            "extracted_events": [
                {
                    "range": [
                        {
                            "introduced": "7.4.X"
                        },
                        {
                            "fixed": "7.4.30"
                        },
                        {
                            "introduced": "8.0.X"
                        },
                        {
                            "fixed": "8.0.20"
                        },
                        {
                            "introduced": "8.1.X"
                        },
                        {
                            "fixed": "8.1.7"
                        }
                    ],
                    "source": "AFFECTED_FIELD",
                    "strategy": "StandardRange"
                }
            ]
        }
    ]
}
References

Affected packages

Git / github.com/php/php-src

Affected ranges

Type
GIT
Repo
https://github.com/php/php-src
Events
Database specific
Show details
{
    "extracted_events": [
        {
            "cpe": "cpe:2.3:a:php:php:*:*:*:*:*:*:*:*",
            "range": [
                {
                    "introduced": "7.4.0"
                },
                {
                    "fixed": "7.4.30"
                }
            ],
            "source": "CPE_RANGE"
        },
        {
            "cpe": "cpe:2.3:a:php:php:*:*:*:*:*:*:*:*",
            "range": [
                {
                    "introduced": "8.0.0"
                },
                {
                    "fixed": "8.0.20"
                }
            ],
            "source": "CPE_RANGE"
        },
        {
            "cpe": "cpe:2.3:a:php:php:*:*:*:*:*:*:*:*",
            "range": [
                {
                    "introduced": "8.1.0"
                },
                {
                    "fixed": "8.1.7"
                }
            ],
            "source": "CPE_RANGE"
        }
    ]
}

Database specific

source
"https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2022-31626.json"