CVE-2023-0568

See a problem?
Source
https://nvd.nist.gov/vuln/detail/CVE-2023-0568
Import Source
https://storage.googleapis.com/cve-osv-conversion/osv-output/CVE-2023-0568.json
JSON Data
https://api.osv.dev/v1/vulns/CVE-2023-0568
Aliases
Related
Published
2023-02-16T07:15:10Z
Modified
2024-05-29T20:52:02Z
Severity
  • CVSS_V3 - CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Summary
[none]
Details

In PHP 8.0.X before 8.0.28, 8.1.X before 8.1.16 and 8.2.X before 8.2.3, core path resolution function allocate buffer one byte too small. When resolving paths with lengths close to system MAXPATHLEN setting, this may lead to the byte after the allocated buffer being overwritten with NUL value, which might lead to unauthorized data access or modification. 

References

Affected packages

Git / github.com/php/php-src

Affected ranges

Type
GIT
Repo
https://github.com/php/php-src
Events